Bug 7355 - samba-3.5.2 - "getent group" not returning any info
samba-3.5.2 - "getent group" not returning any info
Status: RESOLVED WORKSFORME
Product: Samba 3.5
Classification: Unclassified
Component: Winbind
3.5.2
x64 Linux
: P3 normal
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 02:01 UTC by Rob
Modified: 2014-07-24 21:38 UTC (History)
3 users (show)

See Also:


Attachments
Level 10 log.smb (254.28 KB, text/plain)
2010-04-13 02:03 UTC, Rob
no flags Details
Level 10 log.winbindd (443 bytes, text/plain)
2010-04-13 02:13 UTC, Rob
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob 2010-04-13 02:01:55 UTC
I just installed 3.5.2 and encountered the following. Compile worked all
right but "getent group" would not give back any results, though "getent
passwd" did list those AD users. The server runs as AD member and
winbind seems to work normally. "wbinfo -u" and "wbinfo -g" return the
desired info just "getent group" sucks. 
 
It works using the previous 3.3.8 version as well as with 3.4.7 using an
unchanged smb.conf.
Comment 1 Rob 2010-04-13 02:03:49 UTC
Created attachment 5628 [details]
Level 10 log.smb
Comment 2 Rob 2010-04-13 02:13:52 UTC
Created attachment 5629 [details]
Level 10 log.winbindd
Comment 3 Andreas Hauser 2010-06-30 02:47:21 UTC
Same here with 3.5.4. Also %G is resolved to numeric IDs.
getent group GROUP works.
Comment 4 soohoon@gmail.com 2010-09-23 16:31:23 UTC
In my case it works if charget is UTF-8.
If it's something else then
3.5.4
  wbinfo -g doesn't work.
  getent groups doesn't work

3.5.5
  wbinfo -g works.
  getent groups still doesn't work

3.4.9 works fine.
Comment 5 Björn Jacke 2014-07-24 21:38:54 UTC
haven't seen any setup since years where problems like this have been caused by samba itself. mostly it was a configiration problem, nscd not restarted or something like that. closing this old bug now. if u see issues with 4.1, feel free to reopen the bug with verbose description and config files.