Bug 734 - Restarting samba does not clear: connections, locking or brlock tdb's
Restarting samba does not clear: connections, locking or brlock tdb's
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: File Services
2.2.8a
All Linux
: P3 major
: ---
Assigned To: Gerald (Jerry) Carter
http://drouillard.ca
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 07:46 UTC by Gerald Drouillard
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Drouillard 2003-11-07 07:46:54 UTC
Using Mandrake samba-2.2.8a-13mdk:  The connections, locking and brlock tdb in
the  /var/cache/samba directory have to be manually deleted after a samba
shutdown. Then samba has to be started, (creates the .tdb's), shutdown because
it appears that smbstatus gives a locking error, and then restarted.  Reading
other messages on the newsgroup it appears that these databases should be
automatically cleared on a restart.
Comment 1 Daniel Jarboe 2004-02-05 18:42:38 UTC
Cleared on first use is more appropriate description.  Has a new connection 
been received since you restarted?
Comment 2 Gerald Drouillard 2004-02-06 03:49:09 UTC
After working with this for awhile, it also appears that a NT 4 server could
have something to do with this.  I am working with a database application that
uses foxpro databases.  There are many clients during the day that open the
databases (over 50) for use with the client OS being Win95, Win98, WinME, Win2K
and WinXP.  There is one machine that is WinNT4 (with all the patches) which is
used as our batching machine.

Once in awhile we have to kick everone out of the program to do maintenance or
enhancements.  After a smbstatus shows there are currently no open files or
locks, we try to open a database exclusively with no success from any of the
clients except the WinNT4 machine.  A samba restart does not even clear the locks.
Comment 3 Gerald (Jerry) Carter 2004-02-17 08:45:42 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:24:29 UTC
database cleanup