Bug 7297 - smbd crashes with CUPS printers and no [printers] share defined.
smbd crashes with CUPS printers and no [printers] share defined.
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.0rc3
Other Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-25 19:08 UTC by Jeremy Allison
Modified: 2010-03-29 02:01 UTC (History)
0 users

See Also:


Attachments
git am format patch for 3.5.2 and 3.4.8. (977 bytes, patch)
2010-03-25 19:20 UTC, Jeremy Allison
gd: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Allison 2010-03-25 19:08:17 UTC
Create an smb.conf containing no [printers] section, on a machine containing CUPS printers with smbd configured for cups by default.

Start smbd then connect to a printer using:

smbclient //server/printername -Uuser%password

smbd will crash. Caused by incorrect check for iService = -1. This is present on all Samba releases post 3.0.x (I think the change might be connected to the registry shares change).

Patch to follow.

Jeremy.
Comment 1 Jeremy Allison 2010-03-25 19:20:02 UTC
Created attachment 5545 [details]
git am format patch for 3.5.2 and 3.4.8.

Guenther please review for inclusion for 3.5.x and 3.4.x (I've already pushed to master).
Jeremy.
Comment 2 Guenther Deschner 2010-03-27 04:59:35 UTC
Comment on attachment 5545 [details]
git am format patch for 3.5.2 and 3.4.8.

looks fine.
Comment 3 Guenther Deschner 2010-03-27 04:59:59 UTC
Karolin, please add to 3.5 and 3.4
Comment 4 Karolin Seeger 2010-03-29 02:01:15 UTC
Pushed to v3-5-test and v3-4-test.
Closing out bug report.

Thanks!