Bug 7271 - Backends: net newuser failing with OpenLDAP Backend
Backends: net newuser failing with OpenLDAP Backend
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
unspecified
Other Windows XP
: P3 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-21 11:14 UTC by Dirk Pauli
Modified: 2010-11-15 12:54 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Pauli 2010-03-21 11:14:15 UTC
Hi,
using samba 4 (commit 09f270e748263f2fb02683a9376ae185a5534178) against OpenLDap 2.4.21 on Ubuntu server 9.10, I provisioned a new domain.
Afterwards, I tried to create a new user, which is failing:
**********************************************************************
net newuser TestUsr
New Password: 
pdc_fsmo_init: no domain object present: (skip loading of domain details)

naming_fsmo_init: no partitions dn present: (skip loading of naming contexts details)

schema_load_init: no schema head present: (skip schema loading)

Traceback (most recent call last):
  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/__init__.py", line 96, in _run
    return self.run(*args, **kwargs)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/newuser.py", line 70, in run
    force_password_change_at_next_login_req=must_change_at_next_login)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/samdb.py", line 129, in newuser
    "objectClass": "user"})
_ldb.LdbError: (32, 'objectclass: Cannot add CN=TestUsr,CN=Users,DC=test,DC=local, parent does not exist!')
***************************************************************************
Any hints whether I am doing something wrong?
Comment 1 Andrew Bartlett 2010-03-21 19:50:14 UTC
Firstly, can you determine if it also happens when you use the normal LDB backend?

This will help us narrow down the cause.
Comment 2 Dirk Pauli 2010-03-22 13:40:24 UTC
without OpenLDap, I see no problem here
Comment 3 Matthias Dieter Wallnöfer 2010-03-28 13:21:16 UTC
Might be an issue for Endi.
Comment 4 Matthias Dieter Wallnöfer 2010-03-28 13:30:36 UTC
Dirk, how does this work now?
Comment 5 Dirk Pauli 2010-03-29 04:53:54 UTC
it is getting worse - I cannot even provision now. see Bug 7304
Comment 6 Matthias Dieter Wallnöfer 2010-04-10 07:38:52 UTC
And what is with this, Dirk? Could you please retest?
Comment 7 Dirk Pauli 2010-04-10 08:20:42 UTC
not testable due to bug 7344
Comment 8 Dirk Pauli 2010-04-16 14:41:41 UTC
still fails for me:
net newuser TestUsr
New Password: 
pdc_fsmo_init: no domain object present: (skip loading of domain details)

naming_fsmo_init: no partitions dn present: (skip loading of naming contexts det
ails)

schema_load_init: no schema head present: (skip schema loading)

module schema_load initialization failed
module kludge_acl initialization failed
module operational initialization failed
module acl initialization failed
module descriptor initialization failed
module objectclass initialization failed
module asq initialization failed
module server_sort initialization failed
module paged_results initialization failed
module lazy_commit initialization failed
module rootdse initialization failed
module samba_dsdb initialization failed
Unable to load modules for /usr/local/samba/private/sam.ldb: (null)
Traceback (most recent call last):
  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/__init__.py", 
line 99, in _run
    return self.run(*args, **kwargs)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/newuser.py", l
ine 64, in run
    lp=lp)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/samdb.py", line 47, i
n __init__
    options=options)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/__init__.py", line 11
1, in __init__
    self.connect(url, flags, options)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/samdb.py", line 54, i
n connect
    options=options)
_ldb.LdbError: (80, None)
Comment 9 Matthias Dieter Wallnöfer 2010-04-17 07:59:45 UTC
Please retry this with "net user add" since "net newuser" could be dropped soon (bug #7360).
Comment 10 Dirk Pauli 2010-04-17 10:41:37 UTC
That's also failing:

net user add TestUsr
Traceback (most recent call last):
  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/__init__.py", line 122, in _run
    return self.subcommands[subcommand]._run(subcommand, *args)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/__init__.py", line 99, in _run
    return self.run(*args, **kwargs)
  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/user.py", line 46, in run
    net.create_user(name)
RuntimeError: NT_STATUS_OBJECT_NAME_NOT_FOUND
Comment 11 Matthias Dieter Wallnöfer 2010-06-07 15:49:30 UTC
Does the problem still happen? Maybe Endi has some idea.
Comment 12 Dirk Pauli 2010-06-08 15:15:29 UTC
retried with latest build (fd9e02d5f3a2d98fe14b10b52c4ca3e654a6bd3e). Still failing:
net user add TestUsr
Traceback (most recent call last):
  File "bin/python/samba/netcmd/__init__.py", line 122, in _run
    return self.subcommands[subcommand]._run(subcommand, *args)
  File "bin/python/samba/netcmd/__init__.py", line 99, in _run
    return self.run(*args, **kwargs)
  File "bin/python/samba/netcmd/user.py", line 46, in run
    net.create_user(name)
RuntimeError: NT_STATUS_OBJECT_NAME_NOT_FOUND
Comment 13 Matthias Dieter Wallnöfer 2010-10-16 12:59:01 UTC
Endi, do you have some time to look at this?
Comment 14 Matthias Dieter Wallnöfer 2010-10-31 12:53:03 UTC
Some work regarding the OpenLDAP backend have been done in the last weeks. Could you retry please? And if it doesn't work update the error outputs?
Comment 15 Matthias Dieter Wallnöfer 2010-11-15 12:54:37 UTC
I will close this until we receive a status update.