Bug 7268 - smbclient Segfaulting when connecting to a share
smbclient Segfaulting when connecting to a share
Status: RESOLVED DUPLICATE of bug 7250
Product: Samba 3.5
Classification: Unclassified
Component: Client Tools
3.5.1
x64 Linux
: P3 major
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-20 20:23 UTC by Will Siddall
Modified: 2010-05-27 05:19 UTC (History)
0 users

See Also:


Attachments
strace output of smbclient connection (36.59 KB, text/plain)
2010-03-20 20:23 UTC, Will Siddall
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will Siddall 2010-03-20 20:23:16 UTC
I have two machines, a server and a client.  The server has been running for a few years with no issues and the share is an unsecured share (doesn't use authentication).  I've had other computers connect and manage files with no issues.  The client is a new os install and just installed Samba.
On the client, if I do a list on the server, it prompts for a password (which I've never had to do), I leave it blank and I get the list of shares.  When I connect to a share, it prompts for the password again and then segfaults.

Just to try, when I connect through Nautilus, it lists the server, but generates an error when I mount the share.

I am attaching the output of strace when i run the connection.
I am running ArchLinux.

Thanks,
Will
Comment 1 Will Siddall 2010-03-20 20:23:53 UTC
Created attachment 5512 [details]
strace output of smbclient connection
Comment 2 Volker Lendecke 2010-03-21 02:46:58 UTC
Can you post the smb.conf of the server please? Bonus would be to run the crashing smbclient under valgrind and post the output.

Thanks,

Volker
Comment 3 Volker Lendecke 2010-03-21 05:53:13 UTC
Can you try https://bugzilla.samba.org/attachment.cgi?id=5515, a patch I uploaded for 7250? I'm not 100% sure this is the same, but it is definitely worth a try.

Thanks,

Volker
Comment 4 Karolin Seeger 2010-05-27 05:19:36 UTC

*** This bug has been marked as a duplicate of bug 7250 ***