Bug 7255 - "printer admin" parameter does not work as expected
"printer admin" parameter does not work as expected
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.1
Other Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 7491 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-16 03:52 UTC by Karolin Seeger
Modified: 2010-06-07 07:04 UTC (History)
1 user (show)

See Also:


Attachments
smbd log of a failing rename attempt (183.39 KB, application/x-gzip)
2010-03-16 03:55 UTC, Karolin Seeger
no flags Details
smb.conf (353 bytes, application/octet-stream)
2010-03-16 03:55 UTC, Karolin Seeger
no flags Details
Test patch for master / 3.5.x. (568 bytes, patch)
2010-03-17 15:46 UTC, Jeremy Allison
gd: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karolin Seeger 2010-03-16 03:52:55 UTC
The "printer admin" is not allowed to e.g. rename printers (printer open fails with access DENIED).

The same operation works fine when logging in as "root" or granting the SePrintOperatorPrivilege.

Seems to be an issue in 3.3.10 also.
Comment 1 Karolin Seeger 2010-03-16 03:55:13 UTC
Created attachment 5502 [details]
smbd log of a failing rename attempt

User "printadm" tries to rename "printer1" to "printer99".
Comment 2 Karolin Seeger 2010-03-16 03:55:53 UTC
Created attachment 5503 [details]
smb.conf
Comment 3 Jeremy Allison 2010-03-17 15:46:14 UTC
Created attachment 5507 [details]
Test patch for master / 3.5.x.

Karolin, can you test this patch please ?

Jeremy.
Comment 4 Karolin Seeger 2010-03-18 04:26:09 UTC
(In reply to comment #3)
> Created an attachment (id=5507) [details]
> Test patch for master / 3.5.x.
> 
> Karolin, can you test this patch please ?
> 
> Jeremy.

Patch works for me! :-)
Thanks a lot!
Comment 5 Guenther Deschner 2010-03-18 04:37:25 UTC
Comment on attachment 5507 [details]
Test patch for master / 3.5.x.

patch looks ok
Comment 6 Guenther Deschner 2010-03-18 04:38:10 UTC
Karolin, please pick for all branches.
Comment 7 Karolin Seeger 2010-03-18 05:29:34 UTC
Pushed to master, v3-5-test and v3-4-test.
Still an issue in 3.3.x, but that's out of maintenance.
Closing out bug report.

Thanks!
Comment 8 Guenther Deschner 2010-06-07 07:04:41 UTC
*** Bug 7491 has been marked as a duplicate of this bug. ***