Bug 7226 - wbinfo --group-info "Domain admins" segfault time to time when running in unit test
wbinfo --group-info "Domain admins" segfault time to time when running in uni...
Product: Samba 4.0
Classification: Unclassified
Component: smbtorture
Other Linux
: P3 major
: ---
Assigned To: Andrew Tridgell
Depends on:
  Show dependency treegraph
Reported: 2010-03-09 06:41 UTC by Matthieu Patou
Modified: 2010-09-11 12:16 UTC (History)
0 users

See Also:

Patch for adding new unittest for wbinfo (1.31 KB, text/x-patch)
2010-03-09 06:42 UTC, Matthieu Patou
no flags Details
Segfault traces (13.61 KB, text/plain)
2010-03-09 12:21 UTC, Matthias Dieter Wallnöfer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2010-03-09 06:41:39 UTC
The problems only happens in make test or make check TESTS=wbinfo.

Running wbinfo --group-info "Domain admins" is ok.
Comment 1 Matthieu Patou 2010-03-09 06:42:17 UTC
Created attachment 5474 [details]
Patch for adding new unittest for wbinfo
Comment 2 Matthias Dieter Wallnöfer 2010-03-09 10:00:58 UTC
ekacnet, is the segmentation fault related to the "wbinfo" as utility? If yes then I have to reassign this to s3.
Comment 3 Matthieu Patou 2010-03-09 11:29:24 UTC
yes but it's s4 winbind which is faulting !
Comment 4 Matthias Dieter Wallnöfer 2010-03-09 12:21:09 UTC
Created attachment 5478 [details]
Segfault traces

Yeah, ekacnet I reproduced the problem (I hope it at least). I ran wbinfo --group-info "Domain admins" against a s4 server in an infinite loop and interrupted it suddenly with "ctrl+c". This I tried multiple times and then I got these stacktraces.
Comment 5 Matthias Dieter Wallnöfer 2010-03-09 12:21:57 UTC
I think that's a case for you tridge.
Comment 6 Matthias Dieter Wallnöfer 2010-04-08 09:05:24 UTC
Ekacnet, could you retry this to see if it still persists?
Comment 7 Matthias Dieter Wallnöfer 2010-09-11 12:16:10 UTC
This should now have been fixed and the patch was pushed to "master".