Bug 7214 - cifs vfs hangs up after accessing reparse points
cifs vfs hangs up after accessing reparse points
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
All Linux
: P3 normal
: ---
Assigned To: Steve French
Depends on:
  Show dependency treegraph
Reported: 2010-03-05 13:15 UTC by Björn Jacke
Modified: 2014-10-19 00:44 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2010-03-05 13:15:26 UTC
when you access a directory which is a reparse point, cifs vfs hangs up soon after that. Any programm trying to access the cifs mount is caught uninterruptable and takes all CPU time it can take.

You can create a reparse point on NTFS (tested with w2k8r2) and reproduce the problem like this:

- call "mountvol" and look for a device UUID you want to mount
- go to a shared directory, let's say c:\temp for example
- md reppoint
- mountvol reppoint \\?\Volume\{2eca078d-5cbc-41d3-aff8-7e8511f60d0e}\
- now go and mount the c:\temp share via cifs vfs, go into the reppoint directory, call "ls" "cd .." "ls". It will probably hang up now.
Comment 1 Suresh Jayaraman (mail address is dead) 2010-04-08 07:00:39 UTC
I tried to reproduce this against a Windows 2003 Server and ls and cd worked just fine.. Is it reproducible only with Windows 98?
Comment 2 Steve French 2014-10-19 00:44:05 UTC
I just tried this with both SMB3 and CIFS mounts to Windows 8.1 using your example scenario and didn't see a problem.  I did add code to 3.17 to work around some problems recognizing "nfs reparse points" on Windows - not sure if that is the reason.

Let me know if you still see this as a problem as I want to improve some special casing of NFS reparse points in SMB3 (for symlinks)