Bug 7210 - can't create GPO with a domain administrator != administrator
can't create GPO with a domain administrator != administrator
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: File services
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Andrew Tridgell
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-04 17:40 UTC by Matthieu Patou
Modified: 2010-03-05 06:40 UTC (History)
0 users

See Also:


Attachments
trace of the exchange between s4 and xp (28.74 KB, application/octet-stream)
2010-03-04 17:41 UTC, Matthieu Patou
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2010-03-04 17:40:22 UTC
When trying to add a GPO with GPMC.msc I got the error message "access denied".

The adminstrator (mat) can create files and dir in the policies directory.
Comment 1 Matthieu Patou 2010-03-04 17:41:01 UTC
Created attachment 5460 [details]
trace of the exchange between s4 and xp
Comment 2 Matthieu Patou 2010-03-04 17:41:39 UTC
Comment on attachment 5460 [details]
trace of the exchange between s4 and xp

Problem occur (to my mind) at packet 83 and 84
Comment 3 Andrew Tridgell 2010-03-04 23:11:56 UTC
I've reproduced the problem and I'm working on a fix.

Meanwhile, a workaround is to set group write permissions on the group
policies directory on the sysvol share:

 chmod -R g+w Policies

Cheers, Tridge
Comment 4 Matthieu Patou 2010-03-04 23:56:39 UTC
Hi tridge,

I tried to give broader rights on the sysvol folder but unfortunately it didn't works for me (I made it world writable)

root@ares:/home/mat/workspace/samba/homematwsnet/sysvol# ls -rtla
total 0
drwxrwxrwx 4 mat  Domain Admins 4096 2010-02-28 15:51 home.matws.net
-rw-rw-rw- 1 root Domain Admins   92 2010-02-28 15:55 t
drwxrwxrwx 2 mat  Domain Admins    6 2010-02-28 16:22 test
drwxrwxrwx 4 mat  Domain Admins 4096 2010-02-28 16:22 .
Comment 5 Matthias Dieter Wallnöfer 2010-03-05 06:40:17 UTC
Should be fixed by patches of tridge and abartlet in latest GIT releases.