Bug 72 - linux 2.5.69 causes smbd to misbehave and make win98 clients unable to traverse directories
linux 2.5.69 causes smbd to misbehave and make win98 clients unable to traver...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
All Linux
: P5 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-07 00:48 UTC by Ed Sweetman
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Sweetman 2003-05-07 00:48:58 UTC
Everything was working as expected with 2.5.58 and upon upgrading to 2.5.69,
windows 98 clients cannot see file properties of the files it can read (only
those in the top level dir supplied by path=) and it cannot traverse
subdirectories of the path supplied for the given share, displaying an error
"folder <blah> does not exist."  I'm using a guest configuration so
authentication methods are not to blame and the permissions are all correct.  I
can mount the share on linux machines and everything is perfectly fine.  I
couldn't see any errors given by running smbd with debug level 5  and i've tried
setting up my config to not allow kernel oplocks to try and remove kernel
dependency but still nothing. I also tryied setting Max protocol to core plus
but no luck.  My kernel config did not change in between versions and the
underlying fs for all my samba shares is ext3 with posix acl's. No default nls
was set for smbfs.
Comment 1 Ed Sweetman 2003-05-07 01:08:45 UTC
Some other things about my configuration is that sendfile causes no files to be
readable on top of previous problem described so it's disabled in my config.
kernel oplocks dont seem to hurt and i have share level access enabled.  The
directories are all being reported as "file" on the windows 98 machines when i
right click and hit properties. Even when max protocol is set to NT1 from my
conservative setup of coreplus. 
Comment 2 Gerald (Jerry) Carter 2003-05-08 15:01:57 UTC
Lowering priority since this is an unstable kernel.  Probably won't
look at this until bug can be reproduced on a stable kernel.
Might want to refile bug on lkml.

Comment 3 Gerald (Jerry) Carter 2004-01-26 10:33:58 UTC
does this still exist in 2.6 and Samba 3.0.2rc1
Comment 4 Gerald (Jerry) Carter 2004-02-10 15:21:06 UTC
no more feedback.  closing out.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:18:55 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:29:26 UTC
database cleanup