Bug 7189 - Open txt files with notepad on samba shares creates problem.
Open txt files with notepad on samba shares creates problem.
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: File services
unspecified
x86 Linux
: P3 minor
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-01 09:36 UTC by Anton
Modified: 2010-03-05 03:51 UTC (History)
0 users

See Also:


Attachments
tcpdump (362.22 KB, application/octet-stream)
2010-03-01 09:37 UTC, Anton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton 2010-03-01 09:36:44 UTC
When im trying to open a txt files on a s4 share with notepad (running as administrator), i get the error "unknown parameter" i can both read and write with other programs as normal. 
My client is windows 7, im running a s4 that i got last friday from rsync.
Comment 1 Anton 2010-03-01 09:37:09 UTC
Created attachment 5436 [details]
tcpdump
Comment 2 Andrew Tridgell 2010-03-04 22:03:47 UTC
I've reproduced the bug, and I am testing a fix for it now. The fix 
should be in the git master tree in a couple of hours.

Thanks for the bug report!

Cheers, Tridge
Comment 3 Anton 2010-03-05 02:56:19 UTC
(In reply to comment #1)
> Created an attachment (id=5436) [details]
> tcpdump
> 

C(In reply to comment #2)
> I've reproduced the bug, and I am testing a fix for it now. The fix 
> should be in the git master tree in a couple of hours.
> 
> Thanks for the bug report!
> 
> Cheers, Tridge
> 

Cool, just of curiosity, what was the problem?
Comment 4 Andrew Bartlett 2010-03-05 03:51:44 UTC
Samba was rejecting certain flags, because it wanted to use those internally (and so didn't want the client setting them).  We now no longer use them internally (we use a private flag in a different structure).