Bug 716 - Citrix Metaframe, connection to share denied when many users are logged on
Citrix Metaframe, connection to share denied when many users are logged on
Status: RESOLVED FIXED
Product: Samba 2.2
Classification: Unclassified
Component: File Services
2.2.6
All Solaris
: P3 normal
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-04 06:35 UTC by Per Kjetil Grotnes
Modified: 2006-07-05 13:43 UTC (History)
3 users (show)

See Also:


Attachments
remove MAX_CONNECTIONS limit (3.37 KB, patch)
2003-12-10 16:37 UTC, James Peach (outdated mail address)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Per Kjetil Grotnes 2003-11-04 06:35:55 UTC
When there are many users logged on to a Citrix Metaframe server the 
connections to shares start to fail.  You get the popular red cross on mapped 
drives and error when saving documents to the samba server.

To reproduce you would need to 
- have a default compiled Samba installation of any version 
- get a large amount of connections from a single windows client to the samba 
server.  Typically a Citrix Metaframe server with more than 50 users with 10 
shares connected each.  

You would now start to get connection problems to shares.  Mapped drives that 
had timed out wont be able to reconnect to the share.

This error occurs on Windows 2000 Citrix Metaframe server with samba version 
2.2.6.  

It will also happen with other samba versions and all variants of Citrix 
Metaframe.

Reason of the error is when the number of shares connected to the Samba server 
from the Metaframe server raise beyond the MAX_CONNECTIONS default value 
in "smbd/conn.c".  To fix this you have to set the MAX_CONNECTIONS value to a 
larger value before compiling the source.  

conn.c:#define MAX_CONNECTIONS 256

to 

conn.c:#define MAX_CONNECTIONS 1024

Solves the problem.
Comment 1 James Peach (outdated mail address) 2003-12-10 16:37:22 UTC
Created attachment 316 [details]
remove MAX_CONNECTIONS limit

The attached patch removes the MAX_CONNECTIONS limit by
growing the connections bitmap in increments of 128.
Comment 2 Jeremy Allison 2003-12-11 11:58:44 UTC
Great patch. Applied. Thanks
Jeremy.
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:31:23 UTC
database cleanup
Comment 4 Gerald (Jerry) Carter 2006-07-05 13:43:53 UTC
*** Bug 3841 has been marked as a duplicate of this bug. ***