Bug 7142 - Provision gets IP address wrong
Provision gets IP address wrong
Status: RESOLVED DUPLICATE of bug 5484
Product: Samba 4.0
Classification: Unclassified
Component: Tools
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-16 21:31 UTC by John H Terpstra
Modified: 2010-02-17 12:44 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John H Terpstra 2010-02-16 21:31:16 UTC
Try running provision with the following /etc/hosts file:
 
 127.0.0.1	localhost
 127.0.0.2	aragon.example.com aragon
 172.16.10.30	aragon.example.com aragon
 
Then take a look at the zone file that is generated.  The host IP is 127.0.0.2.
 
The provision script could instead refuse IP 127.* that resolves to the
hostname, then check for a valid network IP.  If it can not find it,  do
a DNS lookup; if that fails, bomb-out with an appropriate message.
Comment 1 Matthias Dieter Wallnöfer 2010-02-17 12:44:06 UTC
Exactly this issue I pointed out nearly two years ago and abartlet told me that I have to live with this since the provision can't distinguish between the various IPs and simply takes the first one. To workaround this issue use the "--host-ip" option of the provision script.


*** This bug has been marked as a duplicate of bug 5484 ***