Bug 71 - Delete veto files = No only protects the veto files/directories when they are two or more levels deep
Delete veto files = No only protects the veto files/directories when they are...
Status: RESOLVED LATER
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
Other other
: P5 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 11:55 UTC by Marc Kaplan
Modified: 2005-02-05 07:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Kaplan 2003-05-06 11:55:29 UTC
So let's set I have the following option in my smb.conf


[share1]


path = /home/share1


veto files = /no-see*/


delete veto files = No




Now, I have the following directory structure:


/home/share1/yes-see1/


                   no-see-file1


                   no-see-file2




/home/share1/yes-see2/


                   no-see-dir/


                            no-see-file2




Delete veto files = No is only protecting the /home/shares/yes-see2 directory, 
and not the /home/share1/yes-see1 directory.




So the problem is Delete veto files doesn't work when the vetoed 
files/directories are a single level deep. 




Compounding this problem is the fact that the man page is very confusing, see 
below how the first and second sentences say very different things:


"option is used when Samba is attempting to delete a directory that contains one 
or more vetoed directories (see the veto files option). If this option is set to 
no (the default) then if a vetoed directory contains any non-vetoed files or 
directories then the directory delete will fail. 




The first sentence says that this is used when samba attempts to delete a 
directory (non-vetoed, I assume) that has vetoed directories inside of it. The 
second refers to a vetoed directory containing other vetoed directories. These 
are two very different cases.




I think that the delete veto files = no should prevent the case where you have a 
single vetoed file/directory inside a non-vetoed directory. And this part of the 
smb.conf man page from the veto files section seems to support that:


"One feature of the veto files parameter that it is important to be aware of is 
Samba's behaviour when trying to delete a directory. If a directory that is to 
be deleted contains nothing but veto files this deletion will fail unless you 
also set the delete veto files parameter to yes".
Comment 1 Gerald (Jerry) Carter 2003-12-12 08:27:56 UTC
reseting target milestone.  3.0.1 has been frozen.  WIll have to 
re-evaluate these.
Comment 2 Gerald (Jerry) Carter 2004-05-27 04:02:52 UTC
apparently no one is going to do anything with this. 
Setting priority to P5.
Comment 3 Gerald (Jerry) Carter 2005-01-31 09:39:09 UTC
cleaning up old non-production versions
Comment 4 Gerald (Jerry) Carter 2005-02-05 07:50:33 UTC
later.