Bug 7097 - msdos workstation client problem
msdos workstation client problem
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.3
x64 Linux
: P3 regression
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-03 20:25 UTC by James L. Hurlburt
Modified: 2010-02-07 10:31 UTC (History)
0 users

See Also:


Attachments
segment of the log.smbd for the time period of interest (145.84 KB, text/plain)
2010-02-03 20:27 UTC, James L. Hurlburt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James L. Hurlburt 2010-02-03 20:25:22 UTC
Platform and os is the server.
Client is running MSDOS 6.22 with lanman 2.2
Client works on samba 3.0.23, fails when I tried to upgrade to 3.2.3.

Test smb.conf  

> # Samba config file created using SWAT
> # from UNKNOWN ()
> # Date: 2010/02/02 13:20:51
>
> [global]
>       workgroup = ATRIUM-DW
>       guest account = bbijimhur
>       lanman auth = Yes
>       ldap ssl = no
>
> [bestbilt]
>       comment = working production data
>       path = /atrium/bestbilt
>       username = bbijimhur
>       valid users = @users
>       force group = users
>       read only = No
>       guest ok = Yes
>
> [dosbbilt]
>       comment = win94 for dos workstations
>       path = /atrium/bestbilt
>       read only = No
>       guest ok = Yes
 ******************************************

I can log in on the dos station and map the share.
When I attempt to run an executable I get the following message on the dos station.

> u:\win94\>  Tracking
>
> NET805: NETWORK DEVICE NO LONGER EXISTS READING DRIVE U
>
> Abort, Retry, Fail?
>
> f
>
> Access denied.

I sent Gunter Kukkukk a section of the log.smbd at log level 10 for the time period of interest.  About 3000 lines.

When I attemped to post it here, bugzilla said "too big"
I will be more than happy to send log files or anything else on request

Jim
Comment 1 James L. Hurlburt 2010-02-03 20:27:54 UTC
Created attachment 5269 [details]
segment of the log.smbd for the time period of interest

Duplicate of log sent to Gunter Kukkukk
Comment 2 Volker Lendecke 2010-02-07 10:31:46 UTC
Ok, this is a crash somewhere in smbd. There have been some changes in the chain_reply code since 3.2.3 was released to fix crashes, so I will assume that this is fixed in later releases. Please retry with 3.4.5, or if for some reason you have to stay on 3.2, please retry with 3.2.15, the latest 3.2 release.

If it still happens with this release, please reopen this bug.

Volker