Bug 7083 - Problems with uppercase extensions on fat32
Problems with uppercase extensions on fat32
Status: RESOLVED INVALID
Product: rsync
Classification: Unclassified
Component: core
3.1.0
x86 Linux
: P3 minor
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-31 06:54 UTC by StephanN
Modified: 2010-01-31 14:48 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description StephanN 2010-01-31 06:54:06 UTC
Hi.

When i try to copy files from a samba-mounted ntfs-Server on Debian to a remote fat32 Partition on Debian, i get problems with uppercase file extensions.
I assume that the problem is only given when i use the delete option.

For example rsync shows me:
deleting group/Ausschreibung/Ausschreibung/Statistik/jh92c3~1.xls
group/Ausschreibung/Ausschreibung/Statistik/JH92C3~1.XLS

In fact the new file on the target server is:
$ ls /backups/tsk/group/Ausschreibung/Ausschreibung/Statistik/
jh92c3~1.xls

The partition ist mounted on the right way with option "shortname=mixed". I can create JH92C3~1.XL on the target Server, but rsync can't. So rsync trys to delete an update everytime the same files.

Greetings,
Stephan
Comment 1 StephanN 2010-01-31 07:02:29 UTC
Sorry, i wanted to write:
 So rsync trys to delete _and_ update everytime the same files.



Comment 2 Matt McCutchen 2010-01-31 14:48:16 UTC
See http://rsync.samba.org/FAQ.html#2 .  If the filesystem fails to preserve the case of the name that rsync passes, that would result in the behavior you described.  That is not rsync's fault.

You can try fiddling with the samba options or use the "ignore-case.diff" maintained patch to rsync to work around the problem.