Bug 7075 - bug in vfs_scannedonly rmdir implementation
bug in vfs_scannedonly rmdir implementation
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: VFS Modules
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 05:01 UTC by Olivier Sessink
Modified: 2010-03-24 04:19 UTC (History)
0 users

See Also:
kseeger: review?


Attachments
patch rmdir-called-NEXT_CLOSEDIR-instead-of-NEXT_RMDIR (841 bytes, patch)
2010-01-29 05:02 UTC, Olivier Sessink
no flags Details
git-am patch for 3.5.0 (1.25 KB, patch)
2010-02-04 18:27 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Sessink 2010-01-29 05:01:27 UTC
the rmdir implementation in vfs_scannedonly calles NEXT_CLOSEDIR instead of NEXT_RMDIR. Will attach a patch.
Comment 1 Olivier Sessink 2010-01-29 05:02:54 UTC
Created attachment 5246 [details]
patch rmdir-called-NEXT_CLOSEDIR-instead-of-NEXT_RMDIR

patch against git 3.5-stable
Comment 2 Jeremy Allison 2010-02-04 18:27:27 UTC
Created attachment 5276 [details]
git-am patch for 3.5.0

I think this is correct, your patch still called CLOSEDIR not RMDIR. Once you confirm I'll re-assign to Karolin for inclusion in 3.5.0.

Jeremy.
Comment 3 Olivier Sessink 2010-02-05 01:38:25 UTC
that patch looks better indeed. 

One thing that I am not sure about: could there be a situation where opendir() would return NULL, but rmmdir() would be succesfull?

In that case you should not return -1 if opendir() fails, but return SMB_VFS_NEXT_RMDIR(handle, path);

(if the directory is 100% empty, rmmdir will succeed)
Comment 4 Olivier Sessink 2010-03-23 16:37:36 UTC
ping..

several other people have contacted me because of this issue in rmmdir. Why is the patch not yet applied? Is there something I can do?
Comment 5 Jeremy Allison 2010-03-23 17:43:00 UTC
Re-assigning to Karolin for inclusion in 3.5.2.

Confirmed by author.

Jeremy.
Comment 6 Volker Lendecke 2010-03-24 04:15:22 UTC
Loooks good, please include it in v3-5-test

Thanks,

Volker
Comment 7 Karolin Seeger 2010-03-24 04:19:04 UTC
Pushed to v3-5-test.
Closing out bug report.

Thanks!