Bug 7073 - Samba 3.4.5 core dumps when printing to network printer
Samba 3.4.5 core dumps when printing to network printer
Status: RESOLVED DUPLICATE of bug 7063
Product: Samba 3.4
Classification: Unclassified
Component: Printing
x64 Linux
: P3 critical
: ---
Assigned To: Guenther Deschner
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2010-01-28 02:19 UTC by Dan Gynn
Modified: 2010-02-08 05:41 UTC (History)
1 user (show)

See Also:

Tar & Gziped log files and core dump (261.45 KB, application/octet-stream)
2010-01-28 02:25 UTC, Dan Gynn
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Gynn 2010-01-28 02:19:30 UTC
I have a DC setup on a CentOS 5 install.  It works fine for all expected functions with the stock Samba install.  I'm trying to upgrade to samba 3.4 to get the Windows 7 support.  I have installed the 3.4.5 packages via yum from sernet.  Every function seems to work good except when I attempt to print to a samba served network printer, samba core dumps.  Other printer functions work (such as connecting to the printer or seeing it's properties from Windows).
Comment 1 Dan Gynn 2010-01-28 02:25:27 UTC
Created attachment 5235 [details]
Tar & Gziped log files and core dump

Attaching file containing the messages from /var/log/messages and the debug level 3 messages for the client (user-pc.log).  Also contains the core dump.
Comment 2 Guenther Deschner 2010-02-08 05:41:13 UTC
Looks like a duplicate of the _spoolss_EnumPrinterData bug #7063 to me.

*** This bug has been marked as a duplicate of bug 7063 ***