Bug 7054 - X account flag does not work when pwdlastset is 0
X account flag does not work when pwdlastset is 0
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Domain Control
unspecified
Other All
: P3 regression
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-22 09:02 UTC by Björn Jacke
Modified: 2011-05-26 18:15 UTC (History)
3 users (show)

See Also:


Attachments
git-am fix for 3.6.0 (2.14 KB, patch)
2011-05-24 00:17 UTC, Jeremy Allison
jmcd: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2010-01-22 09:02:20 UTC
An NT4 PDC will clear the "user must change password at next logon" setting when the user has the setting "password must never cahnge".

On a samba PDC a client loggin on gets the message that the password expires today.
Comment 1 Björn Jacke 2010-01-26 09:52:21 UTC
Raising Version to 3.5.0. For a .0 release I would consider this to be a blocker.
Comment 2 Karolin Seeger 2010-02-05 04:42:45 UTC
Samba 3.5.0 is scheduled for February 16.
Is there a chance to get this one fixed until February 9?
Please comment if we should delay 3.5.0 due to this bug if the patch won't be available in time.

Thanks!
Comment 3 Karolin Seeger 2010-02-08 03:03:53 UTC
As this is a very long standing one, I will mark it as a blocker for 3.6.
It's too late for 3.5.0.

Re-assigning to Volker.
Comment 4 Jeremy Allison 2011-05-24 00:17:57 UTC
Created attachment 6479 [details]
git-am fix for 3.6.0

Jim, I think this is the correct fix - please test with NT4.0 usrmgr.

Thanks !

Jeremy.
Comment 5 Jim McDonough 2011-05-24 17:00:43 UTC
Comment on attachment 6479 [details]
git-am fix for 3.6.0

Yep, this seems to do it.  The first part i should be smacked for.  The second part is the subtle one.
Comment 6 Jim McDonough 2011-05-24 17:02:26 UTC
Karo, can we include this in 3.6, please?
Comment 7 Karolin Seeger 2011-05-26 18:15:21 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks a lot!