Bug 7032 - Warning about readdir when building ctdb
Warning about readdir when building ctdb
Status: RESOLVED FIXED
Product: CTDB
Classification: Unclassified
Component: ctdb
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-12 08:59 UTC by Chuck Short
Modified: 2016-08-06 10:01 UTC (History)
1 user (show)

See Also:


Attachments
Fix-broken-readdir.patch (1.69 KB, patch)
2011-03-23 21:32 UTC, Mathieu Parent
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Short 2010-01-12 08:59:17 UTC
When building ctdb we get the following warning:

checking a usable readdir()... no
configure: WARNING: the provided readdir() is broken
checking ifaddrs.h usability... yes

This is due to os2_delete.c being in the wrong place. I have attached a patch to fix this warning.

If you have any questions please let me know.

Regards
chuck
Comment 1 Michael Adam 2010-01-12 09:52:01 UTC
Hi Chuck,

thanks for your report.

(In reply to comment #0)
> When building ctdb we get the following warning:
> 
> checking a usable readdir()... no
> configure: WARNING: the provided readdir() is broken
> checking ifaddrs.h usability... yes
> 
> This is due to os2_delete.c being in the wrong place. I have attached a patch
> to fix this warning.

Not yet, apparently. :-)
 
> If you have any questions please let me know.

I am building current ctdb master on ubuntu 9.10
without such error. Actually, there is no mention 
of readline in all of config.log.

readline is not used in all of ctdb, either.

So here are some questions:

* what version of ctdb are you trying to build?
* are these vanilla sources or are ther patches on top?
* what is your configure command line?
* what version and distribution of Linux are you running?
  (presumably ubuntu 9.10)
* could you pleas attach the produced config.log ?

Cheers - Michael

> Regards
> chuck

Comment 2 Michael Adam 2010-02-24 05:23:30 UTC
Hi Chuck,

any news / answers to my questions?

Michael
Comment 3 Mathieu Parent 2011-03-23 21:32:50 UTC
Created attachment 6343 [details]
Fix-broken-readdir.patch

Attached patch taken from http://bugs.debian.org/603155
Comment 4 Mathieu Parent 2011-07-22 22:25:14 UTC
Does the patch looks good?

Any change to include it?
Comment 5 Mathieu Parent 2011-10-15 13:43:01 UTC
Checked in:

http://git.samba.org/?p=ctdb.git;a=commitdiff;h=29474420606e802c83b53ef5f8e372c8eeac83c1

Can someone close this bug?
Comment 6 Martin Schwenke 2016-08-06 10:01:11 UTC
Confirmed fixed many years ago, closing...