Bug 6996 - syncing backups - autodetect older variants already existing on receiver
syncing backups - autodetect older variants already existing on receiver
Status: RESOLVED DUPLICATE of bug 2294
Product: rsync
Classification: Unclassified
Component: core
Other Linux
: P3 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2009-12-17 02:56 UTC by Michael Monnerie
Modified: 2009-12-21 12:35 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Michael Monnerie 2009-12-17 02:56:53 UTC
We use virtualization, each server makes it's backup to a central backup server. That backup server rsyncs every day the diffs to another site.

Many of the servers make a "backup.tar.bz2", and keep the older version as "backup.tar.bz2.old" or "backup_old.tar.bz2". These files tend to be large, so it would be nice not to sync them, just rename them on the receiver site.

rsync currently transfers the "*old*" version despite it exists already on the receiver, it's just still named "backup.tar.bz2" and would need to be renamed to "backup_old.tar.bz2" (or backup.tar.bz2.old depending on how it is named now).

It would be very interesting to have a feature to search
- within the same dir for files with "similar" names and autodetect if they are the same
- within the same dir for subdirs which have the same content and have just been renamed. This is for backups that do "backup/0", "backup/1", and so on, just renaming the dirs each day.

That should result in just a rename on the receiver side. It could reduce the backup traffic a lot. Maybe name that options "--search-similar"

I think nearly everybody uses "generations" of backups, just renaming them on the original server. So this would free the Internet of unneccessary traffic during the night.
Comment 1 Wayne Davison 2009-12-21 12:35:38 UTC
See the --fuzzy option for some existing support.   Support for renamed files is currently covered by bug 2294, and some support for it in 3.0.x exists in the official patches.

*** This bug has been marked as a duplicate of bug 2294 ***