Bug 6951 - Serious performance issues when using "use sendfile = yes " on Solaris
Serious performance issues when using "use sendfile = yes " on Solaris
Status: RESOLVED DUPLICATE of bug 5512
Product: Samba 3.4
Classification: Unclassified
Component: File services
3.4.2
Sparc Windows XP
: P3 major
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-02 03:28 UTC by Mikhail Zuskov
Modified: 2010-02-07 17:10 UTC (History)
0 users

See Also:


Attachments
d1 log of client having the described problem. (4.41 KB, application/octet-stream)
2009-12-02 03:30 UTC, Mikhail Zuskov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Zuskov 2009-12-02 03:28:31 UTC
Recently we've moved all of our file servers from 3.0.x to 3.4.2. Our users started complaining about performance issues like slow logon, file copy making more time to complete etc. Today i've tried to set "use sendfile = yes" as we've been using than for our 3.0.x configuration and it did increase the performance then.
During the next few minutes after i've enabled this feature we've received the rain of complains from users nor being able to log-in etc. After i've removed "use sendfile" from smb.conf everything went back to "normal".
We've got 2 Solaris 9 servers, the reset is Solaris 10 and all running on Sparc servers.
Comment 1 Mikhail Zuskov 2009-12-02 03:30:25 UTC
Created attachment 5040 [details]
d1 log of client having the described problem.

Unfortunately i've got only d1 log, because setting it to a higher lever will slow down our production systems.
Comment 2 Volker Lendecke 2010-02-07 17:10:51 UTC

*** This bug has been marked as a duplicate of bug 5512 ***