Bug 695 - dos command "del" failure
dos command "del" failure
Status: VERIFIED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
Other Windows 98
: P4 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 21:39 UTC by admin
Modified: 2003-12-10 22:10 UTC (History)
0 users

See Also:


Attachments
netlogon.bat (61 bytes, text/plain)
2003-11-05 18:40 UTC, admin
no flags Details
smb.conf (1.36 KB, text/plain)
2003-11-05 18:41 UTC, admin
no flags Details
level 10 log from samba-3.0.0 (430.70 KB, text/plain)
2003-11-05 18:42 UTC, admin
no flags Details
level 10 log from samba-2.2.8a (490.78 KB, text/plain)
2003-11-05 18:45 UTC, admin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description admin 2003-10-29 21:39:02 UTC
This report had been lodged before for Samba v2.2.8, but I'd lost the report 
number.

In a DOS session of a Win98 client, I invoke "net use f: \\server\share" to 
mount a network drive f:. When I issue "del f:\file.txt" an error occurs :

    General failure reading drive F
    Abort, Retry, Fail?

Windows Explorer works well. For Samba v2.2.8, I learnt that a solution was to 
set "wide links = yes" in smb.conf . However, this no longer works for v3.0.0.
Comment 1 Gerald (Jerry) Carter 2003-11-04 20:05:41 UTC
works fine using 98se dos windows an 
the current 3.0 cvs tree.  If you are having 
a problem with synbolic links, you need to 
include more details so that we can reproduce
or possible attach a level 10 debug log of 
the failure along with your smb.conf
Comment 2 admin 2003-11-05 18:40:09 UTC
Created attachment 241 [details]
netlogon.bat
Comment 3 admin 2003-11-05 18:41:39 UTC
Created attachment 242 [details]
smb.conf
Comment 4 admin 2003-11-05 18:42:29 UTC
Created attachment 243 [details]
level 10 log from samba-3.0.0
Comment 5 admin 2003-11-05 18:45:38 UTC
Created attachment 244 [details]
level 10 log from samba-2.2.8a
Comment 6 admin 2003-11-05 18:55:19 UTC
My copy of samba-3.0.0 was installed in the usual way, i.e. unpack the 
distribution, run "configure --prefix=/home/test/SMB-3.0.0", "make", and "make 
install".
Then created the "smbpasswd", "smb.conf", and "netlogon.bat" files.
Then fired up "smbd -D" and "nmbd -D".
I could logon to Samba from a Win98SE client, and the netlogon script mapped a 
drive letter.
Then I invoked a MS-DOS prompt and issued the command "F:\>del file.txt", an 
error occurred -
    General failure reading drive F
    Abort, Retry, Fail?
I replied "A" and returned to the prompt. This happened on other clients as 
well.
However, file deletion and other manipulations can still be done from within
Windows Explorer, but then many of my batch scripts fail due to the "del"
failure.
Attached please find the relevant files.
Comment 7 Gerald (Jerry) Carter 2003-12-07 21:55:51 UTC
should be fixed in 3.0.1rc1 according to jra
Comment 8 admin 2003-12-10 21:14:33 UTC
This is to report that samba-3.0.1rc1 does fix this bug.
Comment 9 Gerald (Jerry) Carter 2003-12-10 22:10:02 UTC
Thanks.  Marking it as verified.