Bug 6949 - XP Home SP3 cause internal error in samba
XP Home SP3 cause internal error in samba
Status: RESOLVED WORKSFORME
Product: Samba 3.4
Classification: Unclassified
Component: File services
3.4.3
x86 Linux
: P3 major
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-01 18:34 UTC by Gabor Szelei
Modified: 2012-09-12 08:03 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Szelei 2009-12-01 18:34:37 UTC
Access or authentication cause internal error in samba.

See logs here:
http://spidernest.ath.cx/~phoenix/smb/log.mini

Same resource can be access from XP Pro.
Comment 1 Gabor Szelei 2009-12-01 18:35:58 UTC
Platform is debian
samba was installed from:

ii  samba                                2:3.4.3-1                                       SMB/CIFS file, print, and login server for U
ii  samba-common                         2:3.4.3-1                                       common files used by both the Samba server a
ii  samba-common-bin                     2:3.4.3-1                                       common files used by both the Samba server a
Comment 2 Jeremy Allison 2009-12-01 18:56:34 UTC
Can you try running this under valgrind ? Or if you can't do that can you try capturing this under gdb and getting a stack backtrace with complete symbols ?
Thanks,
Jeremy.
Comment 3 Volker Lendecke 2009-12-02 01:08:28 UTC
Please upload a full debug level 10 log together with your smb.conf and a network trace of that failure. Information on how to create network traces can be found under http://wiki.samba.org/index.php/Capture_Packets.

Thanks,

Volker
Comment 4 Gabor Szelei 2009-12-09 17:08:23 UTC
I have included new logs with level 10:

http://spidernest.ath.cx/~phoenix/smb/log.mini

captured packets:

http://spidernest.ath.cx/~phoenix/smb/packets.tcpdump

smb.conf:

http://spidernest.ath.cx/~phoenix/smb/smb.conf
Comment 5 Volker Lendecke 2009-12-13 07:09:48 UTC
Tried to reproduce with your smb.conf, but I could not so far. I have some comments though:

Your smb.conf has an error. You're using "security=server" without giving a password server. What did you intend by setting it to server?

Unfortunately the debug log is not level 10. Please set "log level = 10" and re-upload "log.mini".

Please also try to install the debuginfo .deb so that we get line numbers for the crash.

Thanks,

Volker
Comment 6 Gabor Szelei 2009-12-14 09:45:35 UTC
The problem seems to be misconfiguration. After fixing those things pointed out its started to work. Thank for you help!
Comment 7 Volker Lendecke 2009-12-14 09:49:34 UTC
I would still like to see the log files I asked for, we should never ever abort.

Thanks,

Volker
Comment 8 Gabor Szelei 2009-12-14 10:00:18 UTC
What log file would you like to see if its not crashing anymore?
Comment 9 Gabor Szelei 2009-12-14 10:04:47 UTC
I take it back. I could access using IP address in the url. It still does not work with NETBIOS name.
Comment 10 Volker Lendecke 2009-12-14 10:05:54 UTC
I would like to see a debug level 10 log of the panic. The one you uploaded was only debug level 1.

Volker
Comment 11 Gabor Szelei 2009-12-14 10:26:27 UTC
Ok. Here you are: 

config with security=server:
http://spidernest.ath.cx/~phoenix/smb/smb.conf-20091214
log with PANIC:
http://spidernest.ath.cx/~phoenix/smb/log.mini-200912014.txt

config with security=user:
http://spidernest.ath.cx/~phoenix/smb/smb.conf-20091214-2
log, access to \\spidernest\tf failed
http://spidernest.ath.cx/~phoenix/smb/log.mini-200912014-2.txt

log, access to \\192.168.0.1\tf successful
http://spidernest.ath.cx/~phoenix/smb/log.mini-200912014-3.txt
Comment 12 Karolin Seeger 2009-12-23 06:28:36 UTC
Lowering severity as it works fine when the password server is set.
Comment 13 Björn Jacke 2012-09-12 08:03:09 UTC
i think this is not an issue in current samba releases. if you still have the problem with latest 3.6, plrease reopen and attach a network sniff made on the client. Thanks!