Bug 6919 - Since 3.2.X, smbd no more provides remote quota management
Since 3.2.X, smbd no more provides remote quota management
Status: RESOLVED DUPLICATE of bug 6642
Product: Samba 3.4
Classification: Unclassified
Component: File services
unspecified
All Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-23 11:17 UTC by Dmitry Butskoy
Modified: 2009-11-24 02:18 UTC (History)
0 users

See Also:


Attachments
Work-arounf patch (527 bytes, patch)
2009-11-23 11:20 UTC, Dmitry Butskoy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Butskoy 2009-11-23 11:17:53 UTC
Since the version 3.2.X, smbd server no more provides remote quota management. Neither using smbcquotas (from a remote machine) nor by the native windows  desktop.

The problem seems to be at smbd/nttrans.c:reply_ntcreate_and_X() function. It calls smbd/reply.c:srvstr_get_path(), which calls smbd/reply.c:check_path_syntax(), which does not allow FAKE_FILE_NAME_QUOTA_WIN32 and FAKE_FILE_NAME_QUOTA_UNIX, as such a name does not contain ":$DATA" at the end...

As result, srvstr_get_path() returns failure "wrong parameter", which is reported to the remote system, and remote system interpretes it as no quota on the server.

The work-around seems to be simple, but I'm not sure whether it is strongly correct.
Comment 1 Dmitry Butskoy 2009-11-23 11:20:10 UTC
Created attachment 4981 [details]
Work-arounf patch

The patch against 3.2.15

With this patch (a kludge? :) ) applied, both smbcquotas and native windows can change quota remotely.

According to the source code, the problem seems to be present in 3.3 and 3.4 as well.
Comment 2 Stefan Metzmacher 2009-11-24 02:18:15 UTC

*** This bug has been marked as a duplicate of bug 6642 ***