Bug 691 - nss_winbind causes core dump on Solaris 8
nss_winbind causes core dump on Solaris 8
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.0
All Solaris
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on: 934
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 04:06 UTC by Svein Olav Bjerkeset
Modified: 2005-11-14 09:31 UTC (History)
0 users

See Also:


Attachments
Source for test-program used to generate the core dump (260 bytes, text/plain)
2003-10-28 04:35 UTC, Svein Olav Bjerkeset
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Svein Olav Bjerkeset 2003-10-28 04:06:11 UTC
Versions tested: 3.0.0, 3.0.1pre2 (CVS from Oct 28, 2003)

Build environment:
==================
LD_LIBRARY_PATH=/usr/local/lib:/usr/local/kerberos/lib
export LD_LIBRARY_PATH
PATH=/usr/ccs/bin:$PATH
export PATH
CC="gcc" \
CPPFLAGS="-I/usr/local/include" \
LDFLAGS="-L/usr/local/kerberos/lib -L/usr/local/lib -
R/usr/local/lib:/usr/local/kerberos/lib \
./configure \
        --prefix=/usr/local/samba \
        --with-krb5=/usr/local/kerberos \
        --with-ldap \
        --with-ads \
        --with-libiconv \
        --with-included-popt \
        --with-pam
gmake

From my /etc/nsswitch.conf
==========================
passwd: files ldap winbind

With this setup, getent passwd lists users in /etc/passwd, then LDAP and
dumps core when trying to get the first user from winbind backend.

My /usr/local/samba/lib/smb.conf:
=================================
[global]
        workgroup = VEGVESEN
        realm = VEGVESEN.NO
        server string = svvtest02
        security = ADS
        preferred master = No
        domain master = No
        ldap ssl = no
        idmap uid = 20000-30000
        idmap gid = 20000-30000
        winbind separator = +

[temp]
        comment = Temporary files
        path = /var/tmp
        read only = No

Backtrace from core dump from 'getent passwd':
==============================================
(gdb) bt full
#0  0xff1c9c34 in nss_getent_u () from /usr/lib/libc.so.1
No symbol table info available.
#1  0xff1c97c4 in nss_getent () from /usr/lib/libc.so.1
No symbol table info available.
#2  0xff218754 in getpwent_r () from /usr/lib/libc.so.1
No symbol table info available.
#3  0x0001140c in dogetpw ()
No symbol table info available.
#4  0x00011278 in main ()
No symbol table info available.
Comment 1 Svein Olav Bjerkeset 2003-10-28 04:35:16 UTC
Created attachment 228 [details]
Source for test-program used to generate the core dump

Short test program used to reproduce the error
Compiled with: gcc -g -o pwent pwent.c
Comment 2 Svein Olav Bjerkeset 2003-10-28 04:38:03 UTC
Backtrace of core dump from pwent test program (see attachment)

(gdb) bt full
#0  0xff2c9c34 in nss_getent_u () from /usr/lib/libc.so.1
No symbol table info available.
#1  0xff2c97c4 in nss_getent () from /usr/lib/libc.so.1
No symbol table info available.
#2  0xff318754 in getpwent_r () from /usr/lib/libc.so.1
No symbol table info available.
#3  0x000106d0 in main (argc=1, argv=0xffbefd1c) at pwent.c:11
        i = 42
        pw = {pw_name = 0xffbef478 "", pw_passwd = 0xffbefc77 "", pw_uid = 
10029, pw_gid = 5000, pw_age = 0xffbefc77 "",
  pw_comment = 0xffbefc77 "", pw_gecos = 0xffbef47f "", pw_dir = 0xffbef48e "", 
pw_shell = 0xffbef49b ""}
        buffer = '\0' <repeats 2047 times>
Comment 3 Steven Tamm 2004-01-02 13:12:27 UTC
I'm fairly certain this is related to my bug "934"
Comment 4 Gerald (Jerry) Carter 2004-04-22 19:58:52 UTC
nss_winbind has gotten several fixes for solaris since 3.0.0.
please reopen if you can reproduce this bug against 3.0.2a.
Thanks.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:20:25 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:31:38 UTC
database cleanup