Bug 6905 - Build system: Failed to build SAMBA4 on OpenSolaris
Build system: Failed to build SAMBA4 on OpenSolaris
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
All Solaris
: P3 normal
: ---
Assigned To: Jelmer Vernooij
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 00:26 UTC by Brian Lu (mail address dead)
Modified: 2009-11-24 16:38 UTC (History)
0 users

See Also:


Attachments
check sun compiler and remove -fullwarn when using sun cc (1.39 KB, patch)
2009-11-19 00:29 UTC, Brian Lu (mail address dead)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Lu (mail address dead) 2009-11-19 00:26:58 UTC
I checked out the latest samba4 trunk code and tried to build it on latest OpenSolaris with latest SunStudio 12 update 1.  The build failed.

The following is what I did:
1. git-clone git://git.samba.org/samba.git samba
2. cd samba/source4
3. ./autogen.sh
4. ./configure.developer --enable-debug

I got following error
checking configure summary... configure: error: summary failure. Aborting config

I checked the config.log and found the root cause is that gcc option '-fullwarn' is passed to sun cc
Comment 1 Brian Lu (mail address dead) 2009-11-19 00:29:21 UTC
Created attachment 4965 [details]
check sun compiler and remove -fullwarn when using sun cc
Comment 2 Matthias Dieter Wallnöfer 2009-11-19 03:38:27 UTC
I would say that the patch is okay but I would also like to hear Jelmer's opinion.
Comment 3 Matthias Dieter Wallnöfer 2009-11-24 16:38:41 UTC
Reviewed and applied. Thanks!