Bug 6904 - Net vampire error
Net vampire error
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
x86 Linux
: P3 normal
: ---
Assigned To: Andrew Bartlett
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-18 12:47 UTC by Mohammad Nazeem Durgahee
Modified: 2009-12-22 04:10 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammad Nazeem Durgahee 2009-11-18 12:47:07 UTC
Hi guys I need help here can anyone help. Also I cannot net vampire to windows it is failing can you plz help with a hwto
INTERNAL ERROR: Signal 11 in pid 6189 (4.0.0alpha9-GIT-a31838e)
Please read the file BUGS.txt in the distribution
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
PANIC: internal error
BACKTRACE: 28 stack frames:
 #0 bin/net(call_backtrace+0x2b) [0x86ef28f]
 #1 bin/net(smb_panic+0x2d4) [0x86ef64f]
 #2 bin/net [0x86ef81a]
 #3 bin/net(fault_setup+0) [0x86ef84f]
 #4 [0xb8006400]
 #5 bin/net(convert_string_talloc_convenience+0x6b) [0x86fe253]
 #6 bin/net(ndr_push_string+0x123) [0x85b91e6]
 #7 bin/net [0x815e104]
 #8 bin/net(irpc_call_send+0x18b) [0x81595ae]
 #9 bin/net [0x8156c10]
 #10 bin/net [0x82360f5]
 #11 bin/net(composite_done+0xa1) [0x824a836]
 #12 bin/net [0x820ca42]
 #13 bin/net [0x86de218]
 #14 bin/net [0x86de8c8]
 #15 bin/net(_tevent_loop_once+0xdf) [0x86dac13]
 #16 bin/net(composite_wait+0x44) [0x824a56e]
 #17 bin/net [0x80dd25b]
 #18 bin/net(libnet_RpcConnect_recv+0xb4) [0x80dd64e]
 #19 bin/net(libnet_RpcConnect+0x5e) [0x80dd6e2]
 #20 bin/net(libnet_JoinDomain+0x197) [0x80deae9]
 #21 bin/net(libnet_Vampire+0x1bd) [0x80eb634]
 #22 bin/net(net_vampire+0x17f) [0x80d2abf]
 #23 bin/net(net_run_function+0xc5) [0x80d11b9]
 #24 bin/net [0x80d16a4]
 #25 bin/net(main+0x22) [0x80d175a]
 #26 /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7a91775]
 #27 bin/net [0x80d1061]
Comment 1 Mohammad Nazeem Durgahee 2009-11-18 12:50:14 UTC
This is bcause we want to use Samba4 in a charity as a replacement for windows 2000 DC. It will be great if somebody can help me. Thanks.
Comment 2 Matthias Dieter Wallnöfer 2009-11-21 06:57:57 UTC
The first step to start investigations about it is to compile SAMBA 4 with "./configure.developer" (to have debugging symbols enabled). Then to launch the "net" command in "gdb" using "gdb --args <net call>". When the error happens type "bt full". Copy and paste those informations here.
Comment 3 Mohammad Nazeem Durgahee 2009-11-21 11:00:12 UTC
(In reply to comment #2)
> The first step to start investigations about it is to compile SAMBA 4 with
> "./configure.developer" (to have debugging symbols enabled). Then to launch the
> "net" command in "gdb" using "gdb --args <net call>". When the error happens
> type "bt full". Copy and paste those informations here.
> 

I found it was dns related now having problem with kdc as it cannot find kdc in relam naz.org any idea wat to do
Comment 4 Matthias Dieter Wallnöfer 2009-11-21 11:15:44 UTC
I suppose you use the built-in Heimdal KERBEROS implementation since at the moment we support only that for s4. KERBEROS should be set up correctly if you follow all the setup steps listed on the wiki (http://wiki.samba.org/index.php/Samba4/HOWTO). Maybe you didn't include the generated zone file in the bind9 DNS server configuration?
Comment 5 Matthias Dieter Wallnöfer 2009-12-15 10:00:46 UTC
Anything left in this bug? I see you filed another one about the vampire where I've answered now - so I think we could close this one.
Comment 6 Matthias Dieter Wallnöfer 2009-12-22 04:10:48 UTC
Here the real problem was KERBEROS misconfiguration. So I close this with "INVALID" (not a bug).