Bug 6894 - infinite looping of smbldap_idle_fn
infinite looping of smbldap_idle_fn
Status: RESOLVED WORKSFORME
Product: Samba 3.3
Classification: Unclassified
Component: User & Group Accounts
3.3.9
Other Linux
: P3 critical
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-13 06:56 UTC by Guenther Deschner
Modified: 2011-05-11 10:56 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2009-11-13 06:56:02 UTC
Sometimes smbd hangs infinitely while looping over the smbldap_idle_fn.

Excerpt from the log:

[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28,  7] lib/smbldap.c:smbldap_idle_fn(1656)
  ldap connection idle...closing connection
[2009/11/13 13:11:28,  5] lib/smbldap.c:smbldap_close(1163)
  The connection to the LDAP server was closed
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28, 10] lib/smbldap.c:smbldap_idle_fn(1641)
  ldap connection not connected...
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28, 10] lib/smbldap.c:smbldap_idle_fn(1641)
  ldap connection not connected...
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28, 10] lib/smbldap.c:smbldap_idle_fn(1641)
  ldap connection not connected...
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28, 10] lib/smbldap.c:smbldap_idle_fn(1641)
  ldap connection not connected...
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28, 10] lib/smbldap.c:smbldap_idle_fn(1641)
  ldap connection not connected...
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28, 10] lib/smbldap.c:smbldap_idle_fn(1641)
  ldap connection not connected...
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
[2009/11/13 13:11:28, 10] lib/smbldap.c:smbldap_idle_fn(1641)
  ldap connection not connected...
[2009/11/13 13:11:28, 10] lib/events.c:run_events(231)
  Running event "smbldap_idle_fn" 896fff8
...
Comment 1 Karolin Seeger 2010-01-11 05:31:07 UTC
Günther, is this a showstopper for Samba 3.3.10 (scheduled for January 14)?
Comment 2 Guenther Deschner 2010-01-13 04:27:18 UTC
Tried hard but cannot reproduce atm. Lowering severity.
Comment 3 Guenther Deschner 2011-05-11 10:56:05 UTC
never saw this happening again