Bug 6862 - infinite loop trying to access truncated serive name,
infinite loop trying to access truncated serive name,
Status: RESOLVED INVALID
Product: Samba 3.3
Classification: Unclassified
Component: File services
3.3.8
x86 Windows Vista
: P3 major
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-31 01:05 UTC by Brian Bayorgeon
Modified: 2009-11-30 16:31 UTC (History)
0 users

See Also:


Attachments
level 10 log from smbd startup until first loop (161.63 KB, text/plain)
2009-10-31 01:09 UTC, Brian Bayorgeon
no flags Details
level 10 log of first loop (62.85 KB, text/plain)
2009-10-31 01:10 UTC, Brian Bayorgeon
no flags Details
level 10 log second repitition ...basically same as first rep (62.85 KB, text/plain)
2009-10-31 01:11 UTC, Brian Bayorgeon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Bayorgeon 2009-10-31 01:05:40 UTC
Server apparently enters an infinite loop while trying to provide access to a truncated service name. In one of many configurations trialed the server and client were exchanging > 1000 smb blocks per second and repeating a loop ~ 200 times per second. This was discussed at large on the mail list under the topics "Lots of smbd processes and connections?" and "New issue with a New Vista Client - couldn't find service"  It appears to be similar to the issue reported here http://lists.samba.org/archive/samba/2009-October/150998.html
or here http://lists.samba.org/archive/samba/2009-March/147277.html

The issue at times goes away, but it is present more than not.

The server process consumes large amounts of CPU time "at idle" and will fill a 500K log file in a matter of seconds at lower log levels.

Snipet from top

  PID USERNAME    THR PRI NICE   SIZE    RES STATE  C   TIME   WCPU COMMAND
16650 root          1 100    0 14688K  6220K CPU2   2  69:59 21.68% smbd

Issue appeared with older version of samba 2.x somthing or another when a new vista client was added to the network.  There after a new server was constructed to replace the older server and the issue persisted with 3.3.8
Comment 1 Brian Bayorgeon 2009-10-31 01:09:56 UTC
Created attachment 4908 [details]
level 10 log from smbd startup until first loop

Well, it was all a delusion.  The problem is not fixed - it has returned.  I have attached to this email 3 files with level 10 logs.  I'm not sure if the attachments will pass to the samba list or not, but I will try.  If not I will resend with the content in the email.

the files are: 

"smbd start to first rep"

is the log from the time the smdb process restarts until the appearance of the first loop repetition.

"rep 1"

is the log of first repetition of things after the server has initialized and the session established with the client.

"rep 2"

is the basically the same as the rep1 

it goes on and on.....
Comment 2 Brian Bayorgeon 2009-10-31 01:10:48 UTC
Created attachment 4909 [details]
level 10 log of first loop

Well, it was all a delusion.  The problem is not fixed - it has returned.  I have attached to this email 3 files with level 10 logs.  I'm not sure if the attachments will pass to the samba list or not, but I will try.  If not I will resend with the content in the email.

the files are: 

"smbd start to first rep"

is the log from the time the smdb process restarts until the appearance of the first loop repetition.

"rep 1"

is the log of first repetition of things after the server has initialized and the session established with the client.

"rep 2"

is the basically the same as the rep1 

it goes on and on.....
Comment 3 Brian Bayorgeon 2009-10-31 01:11:39 UTC
Created attachment 4910 [details]
level 10 log second repitition ...basically same as first rep

Well, it was all a delusion.  The problem is not fixed - it has returned.  I have attached to this email 3 files with level 10 logs.  I'm not sure if the attachments will pass to the samba list or not, but I will try.  If not I will resend with the content in the email.

the files are: 

"smbd start to first rep"

is the log from the time the smdb process restarts until the appearance of the first loop repetition.

"rep 1"

is the log of first repetition of things after the server has initialized and the session established with the client.

"rep 2"

is the basically the same as the rep1 

it goes on and on.....
Comment 4 Brian Bayorgeon 2009-11-09 21:47:56 UTC
Problem solved / culprit found!

Behavior in question:

The last character of the service name is truncated and couldn't find
service

First off, this behavior is pretty well documented....it even appears noted
as an odd behavior in a MS White Paper.  Normally not a big deal as MS
clients would provide a few requests with the truncated service name 
the correct itself.
For example you can get a Windoze client to repeat the situation by
requesting properties of a share from explorer and it will result 
in 3 or 4 truncated service name requests.

My problem was the client was spamming the server with > 1000 requests / sec
flooding logs and bogging down the server.

My situation was related to resident software on the client called:

CyberLink Media Libray
HP TouchSmart
HP MediaSmart

I think they are all basically the same product with different names

One of these processes was spamming the server looking for media I suspect.

I uninstalled it and the spamming stopped.

In particular the problem resided with a process call CLMLSvc.exe.  Once
killed the spamming went away.

Cheers
Brian
Comment 5 Volker Lendecke 2009-11-30 16:31:55 UTC
Fixing as "INVALID". Please re-open if you still think this is a Samba bug.

Thanks,

Volker