Bug 6858 - Samba 3.2.x and 3.3.x mangle names on Solaris 10
Samba 3.2.x and 3.3.x mangle names on Solaris 10
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: File services
unspecified
Sparc Solaris
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-30 02:46 UTC by Francisco Cano Entrena
Modified: 2009-12-23 06:21 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Cano Entrena 2009-10-30 02:46:07 UTC
We are trying to install Samba 3.3.9 with this compilations options:
--with-quotas --with-sys-quotas --with-acl-support
on a Sun Solaris (SunOS hator 5.10 Generic_127127-11 sun4v sparc SUNW,SPARC-Enterprise-T2000).
The compilation ends ok and the installation too but when we start samba the clients with XP SP3 get all filenames mangled, as is they are DOS clients...yes, in the previous version (3.0.34) there was no problems, but with the new one, we cant' work.
In the smb.conf file there is no any strange parameter:

[global]
        workgroup = ADMINISTRACION
        netbios name = HATOR
        server string = Servidor de Administracion (Samba %v)
        interfaces = e1000g0
        bind interfaces only = Yes
        encrypt passwords = Yes
        log level = 0 auth:1
        max log size = 400000
        syslog only = yes
        deadtime = 15
        max xmit = 32768
        socket options = SO_KEEPALIVE=1 TCP_NODELAY=0
        logon script = %a.bat
        domain logons = Yes
        os level = 64
        local master = Yes
        lm announce = Yes
        preferred master = Yes
        domain master = Yes
        logon home =
        logon path = \\hator\perfiles\%U
        hosts allow = 172.18.132.105 172.18.132.110 172.18.132.111 172.18.132.112 172.18.132.113 172.18.132.11
        hosts deny = all
        mangling method = hash
        restrict anonymous = 1
        load printers = no
        add machine script = /usr/sbin/useradd -c "ClienteXP" -d /dev/null -g maquinas -s /bin/false %u
        wins support = Yes
        display charset = UTF8

Please, help us. And sorry for this horrible english.
TIA.
Comment 1 Mike 2009-12-11 23:33:45 UTC
I think this bug and bug 6939 are duplicates.
The problem is with "mangling method = hash" instead of the default "hash2"
Comment 2 Francisco Cano Entrena 2009-12-23 06:21:15 UTC
(In reply to comment #1)
> I think this bug and bug 6939 are duplicates.
> The problem is with "mangling method = hash" instead of the default "hash2"
> 

Ok. Thas was the problem. Thank you very much.