Bug 6856 - GPFS VFS module cannot be built with headers only
GPFS VFS module cannot be built with headers only
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: Build environment
3.4.3
Other Linux
: P3 normal
: ---
Assigned To: Stefan Metzmacher
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 05:45 UTC by Karolin Seeger
Modified: 2010-01-14 04:14 UTC (History)
1 user (show)

See Also:


Attachments
proposed patch provided by Metze (2.04 KB, patch)
2009-10-29 05:47 UTC, Karolin Seeger
obnox: review+
Details
Patch for v3-3 (2.20 KB, patch)
2010-01-14 03:44 UTC, Stefan Metzmacher
kseeger: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karolin Seeger 2009-10-29 05:45:48 UTC
Currently, you need the GPFS library to be able to build the GPFS VFS module, but it should be possible to build with the headers only.

Metze addressed this issue with commit 54d8b2fc in master. This one should be fixed in 3.4 also.
Comment 1 Karolin Seeger 2009-10-29 05:47:04 UTC
Created attachment 4903 [details]
proposed patch provided by Metze
Comment 2 Karolin Seeger 2009-10-30 07:00:43 UTC
Pushed to v3-4-test.
Closing out bug report.

Thanks!
Comment 3 Stefan Metzmacher 2010-01-14 03:44:44 UTC
Created attachment 5177 [details]
Patch for v3-3

We also need this for 3.3.x
Comment 4 Karolin Seeger 2010-01-14 04:14:00 UTC
Pushed to v3-3-test. Will be inlcuded in 3.3.10.
Closing out bug report.

Thanks, Metze!