Bug 6808 - shared build fails to link smbtorture4 when using --enable-external-libtalloc
shared build fails to link smbtorture4 when using --enable-external-libtalloc
Status: RESOLVED FIXED
Product: TALLOC
Classification: Unclassified
Component: libtalloc
2.0.0
Other Linux
: P3 normal
: ---
Assigned To: Simo Sorce
Samba QA Contact
:
: 6709 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 17:03 UTC by Guenther Deschner
Modified: 2009-12-15 10:29 UTC (History)
1 user (show)

See Also:


Attachments
add regenerated symbol table (4.17 KB, patch)
2009-10-14 08:19 UTC, Guenther Deschner
idra: review-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2009-10-13 17:03:20 UTC
/space/src/samba/SOURCES/samba.git/source3/../source4/torture/../../lib/talloc/testsuite.c:521: undefined reference to `talloc_enable_null_tracking_no_autofree'
Comment 1 Guenther Deschner 2009-10-13 17:04:18 UTC
Sorry, here is a bit more context:

Linking bin/smbtorture4
bin/mergedobj/torture_local.o: In function `test_misc':
/space/src/samba/SOURCES/samba.git/source3/../source4/torture/../../lib/talloc/testsuite.c:521: undefined reference to `talloc_enable_null_tracking_no_autofree'
bin/mergedobj/torture_local.o: In function `test_reset':
/space/src/samba/SOURCES/samba.git/source3/../source4/torture/../../lib/talloc/testsuite.c:1140: undefined reference to `talloc_enable_null_tracking_no_autofree'
collect2: ld returned 1 exit status
Comment 2 Guenther Deschner 2009-10-13 17:07:20 UTC
rpm -q libtalloc
libtalloc-2.0.0-0.fc11.i386
Comment 3 Guenther Deschner 2009-10-14 08:11:32 UTC
Ok, the symbols exported by talloc 2.0 are not complete. Patch to follow.
Comment 4 Guenther Deschner 2009-10-14 08:19:24 UTC
Created attachment 4842 [details]
add regenerated symbol table
Comment 5 Simo Sorce 2009-10-14 10:05:54 UTC
Ok I pushed patches to update the export file and also the signatures files
Also added checks in the release script so that we always verify they are correct.

Commit ids:
6618a062a19660a718074f6e6155339451b7a5b6
8fb483b2964f1222c013df42ba8be544269da612
8e6df560b74d7e9b94dd47625de56bc1dc0bc6d7
2d6d6bcb5de87ce0dbce13ff6bc775b953438b75
Comment 6 Simo Sorce 2009-10-14 10:06:48 UTC
Comment on attachment 4842 [details]
add regenerated symbol table

The patch was technically correct but it changed the indentation of the file and didn't address the signatures file
Comment 7 Guenther Deschner 2009-10-28 05:47:36 UTC
Simo, this can be closed now I think. Do you know whether things are ok for 3.4 ?
Comment 8 Björn Jacke 2009-11-07 14:01:53 UTC
*** Bug 6709 has been marked as a duplicate of this bug. ***
Comment 9 Guenther Deschner 2009-12-11 11:32:24 UTC
Simo, can talloc 2.0.1 be released so that we can finally close this one ?
Comment 10 Simo Sorce 2009-12-15 10:29:54 UTC
2.0.1 has been released, closing this bug