Bug 6795 - Problem to compile samba-vscan
Problem to compile samba-vscan
Status: RESOLVED DUPLICATE of bug 6783
Product: Samba 3.2
Classification: Unclassified
Component: VFS Modules
3.2.5
x86 Linux
: P3 normal
: ---
Assigned To: Holger Hetterich
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-09 09:26 UTC by Pascal
Modified: 2010-02-15 17:20 UTC (History)
1 user (show)

See Also:


Attachments
Result of the command make clamav (13.62 KB, text/plain)
2009-10-09 09:28 UTC, Pascal
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal 2009-10-09 09:26:30 UTC
Hello,
i'm trying to make works samba-vscan-0.3.6c with samba 3.2.5.
here is what i do : 
wget http://www.samba.org/samba/ftp/old-versions/samba-3.2.5.tar.gz
wget http://www.openantivirus.org/download/samba-vscan-0.3.6c-beta5.tar.gz
tar -xzf samba-3.2.5.tar.gz
cd samba-3.2.5
cd source
./configure
make proto
cd ../../
tar -xzf samba-vscan-0.3.6c-beta5.tar.gz
cd samba-vscan-0.3.6c-beta5
./configure --with-samba-source=/home/vscan-test/samba-3.2.5/source
make clamav

after make clamav, i've got a lot of error

here is the beginning of error

Compiling global/vscan-functions.c with -fPIC
In file included from /home/vscan-test/samba-vscan-0.3.6c-beta5/include/vscan-global.h:4,
                 from global/vscan-functions.c:15:
/home/vscan-test/samba-3.2.5/source/include/includes.h:652:17: error: tdb.h: No such file or directory


the rest can be seen on pastebin here : http://pastebin.com/m106e5cff

thank you for help
Comment 1 Pascal 2009-10-09 09:28:15 UTC
Created attachment 4826 [details]
Result of the command make clamav
Comment 2 Holger Hetterich 2010-02-15 17:20:19 UTC

*** This bug has been marked as a duplicate of bug 6783 ***