Bug 6734 - samba-3.3.7 crashes - INTERNAL ERROR: Signal 11
samba-3.3.7 crashes - INTERNAL ERROR: Signal 11
Status: RESOLVED DUPLICATE of bug 6696
Product: Samba 3.3
Classification: Unclassified
Component: File services
3.3.7
Other Linux
: P3 regression
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 09:14 UTC by Alexey Shildyakov
Modified: 2009-09-17 12:36 UTC (History)
0 users

See Also:


Attachments
Core dump zipped (132.20 KB, application/zip)
2009-09-16 09:18 UTC, Alexey Shildyakov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Shildyakov 2009-09-16 09:14:25 UTC
After smbclient -L 172.16.50.110
read_socket_with_timeout: timeout read. read error = Connection reset by peer.
Receiving SMB: Server stopped responding
protocol negotiation failed

And after all actions connecting to smb.

[2009/09/16 18:00:40,  0] smbd/server.c:main(1274)
  smbd version 3.3.7 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2009
[2009/09/16 18:01:09,  0] lib/fault.c:fault_report(40)
  ===============================================================
[2009/09/16 18:01:09,  0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 22059 (3.3.7)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2009/09/16 18:01:09,  0] lib/fault.c:fault_report(43)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2009/09/16 18:01:09,  0] lib/fault.c:fault_report(44)
  ===============================================================
[2009/09/16 18:01:09,  0] lib/util.c:smb_panic(1673)
  PANIC (pid 22059): internal error
[2009/09/16 18:01:09,  0] lib/util.c:log_stack_trace(1777)
  BACKTRACE: 8 stack frames:
   #0 /usr/sbin/smbd(log_stack_trace+0x1c) [0x7fa5fc759d17]
   #1 /usr/sbin/smbd(smb_panic+0x5b) [0x7fa5fc759e24]
   #2 /usr/sbin/smbd [0x7fa5fc747041]
   #3 /lib/libpthread.so.0 [0x7fa5fa7f2ee0]
   #4 /usr/sbin/smbd(dns_register_smbd_reply+0x1c) [0x7fa5fc5bba2b]
   #5 /usr/sbin/smbd(main+0x16de) [0x7fa5fc94e5d2]
   #6 /lib/libc.so.6(__libc_start_main+0xe6) [0x7fa5f8f94a26]
   #7 /usr/sbin/smbd [0x7fa5fc542c19]
[2009/09/16 18:01:09,  0] lib/fault.c:dump_core(231)
  dumping core in /var/log/samba/cores/smbd
Comment 1 Alexey Shildyakov 2009-09-16 09:18:28 UTC
Created attachment 4704 [details]
Core dump zipped
Comment 2 Karolin Seeger 2009-09-17 03:15:16 UTC
Marking as a showstopper for 3.3.8.
Comment 3 Björn Jacke 2009-09-17 12:36:43 UTC

*** This bug has been marked as a duplicate of bug 6696 ***