Bug 6708 - net.samba3 crashed with SIGSEGV in free()
net.samba3 crashed with SIGSEGV in free()
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: File services
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 12:09 UTC by Chuck Short
Modified: 2009-09-23 05:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Short 2009-09-10 12:09:03 UTC
Hi,

This was recently reported in launchpad. The debugging information can be found at:

http://bugs.launchpad.net/bugs/421419

If you have any questions please let me know.

Regards
chuck
Comment 1 Jeremy Allison 2009-09-10 12:10:05 UTC
No permission to access the page. Either open up permissions, or log the bug properly here please.
Jeremy.
Comment 2 Chuck Short 2009-09-10 12:18:50 UTC
Sorry about that it should be public now.

Regards
chuck
Comment 3 Jeremy Allison 2009-09-10 12:40:33 UTC
From the launchpad bug:


Binary package hint: samba

Just booted, wasn't doing anything.

ProblemType: Crash
Architecture: amd64
Date: Sat Aug 29 17:00:05 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/net.samba3
NonfreeKernelModules: nvidia
Package: samba-common-bin 2:3.4.0-3ubuntu1
ProcCmdline: net usershare info
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-8.28-generic
SegvAnalysis:
 Segfault happened at: 0x7f585db60e78: cmp 0x18(%rdx),%rbx
 PC (0x7f585db60e78) ok
 source "0x18(%rdx)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rbx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: samba
StacktraceTop:
 ?? () from /lib/libc.so.6
 ?? () from /lib/libc.so.6
 free () from /lib/libc.so.6
 get_interfaces () from /usr/bin/net.samba3
 load_interfaces () from /usr/bin/net.samba3
Title: net.samba3 crashed with SIGSEGV in free()
Uname: Linux 2.6.31-8-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape vboxusers video voice

Ok, this looks to me like it might be a duplicate of bug #6707.

Can you try the patch in that bug please ?

Jeremy.
Comment 4 Guenther Deschner 2009-09-23 05:33:42 UTC
According to that launchpad link, ubuntu has included the fix and this should be resolved.