Bug 6705 - Win Server 2k8 join fails: The specified account already exists
Win Server 2k8 join fails: The specified account already exists
Status: RESOLVED WORKSFORME
Product: Samba 3.4
Classification: Unclassified
Component: Domain Control
3.4.2
x86 Windows 2008
: P3 regression
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 05:45 UTC by Emil Konow
Modified: 2009-10-16 04:43 UTC (History)
1 user (show)

See Also:


Attachments
smb.conf - Samba PDC configuration (374 bytes, text/plain)
2009-09-10 05:46 UTC, Emil Konow
no flags Details
samba.log - Log from Samba machine (1.36 KB, text/plain)
2009-09-10 05:47 UTC, Emil Konow
no flags Details
netsetup.log - Log from Windows machine (6.15 KB, text/plain)
2009-09-10 06:01 UTC, Emil Konow
no flags Details
Creating the Samba users (745 bytes, text/plain)
2009-09-10 06:02 UTC, Emil Konow
no flags Details
netsetup.log - Success! (2.94 KB, text/plain)
2009-09-15 18:13 UTC, Emil Konow
no flags Details
samba.log - Success! (1011 bytes, text/plain)
2009-09-15 18:13 UTC, Emil Konow
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Konow 2009-09-10 05:45:48 UTC
Windows Server 2008 SP2 machine unable to join my freshly installed Samba PDC 3.4.0 Ubuntu Hardy.
When I try to join the domain, I'm prompted for username and password.
After entering my Samba admin credentials I get an error after 3-5 secs:

> The following error occurred attempting to join the domain DEVNET:
> The specified account already exists.
Comment 1 Emil Konow 2009-09-10 05:46:33 UTC
Created attachment 4672 [details]
smb.conf - Samba PDC configuration
Comment 2 Emil Konow 2009-09-10 05:47:12 UTC
Created attachment 4673 [details]
samba.log - Log from Samba machine
Comment 3 Emil Konow 2009-09-10 06:01:20 UTC
Created attachment 4674 [details]
netsetup.log - Log from Windows machine
Comment 4 Emil Konow 2009-09-10 06:02:47 UTC
Created attachment 4675 [details]
Creating the Samba users
Comment 5 Guenther Deschner 2009-09-10 06:15:07 UTC
Do you have a chance to try 3.4.1 (released yesterday) ? It has some important fixes in this regard.
Comment 6 Emil Konow 2009-09-15 18:10:35 UTC
Hi, if there's an apt package available soon for 3.4.1, then I'll try it.
I managed to install 3.4.0 using apt-get from launchpad.net.

On the other hand:
This is very interesting!
I installed Samba 3.2.5 on Debian Lenny,
with the exact same smb.conf, users etc. as above.
Now I'm able to successfully join my Windows machine to this new PDC...!
I have attached samba.log and netsetup.log from this process.
Comment 7 Emil Konow 2009-09-15 18:13:06 UTC
Created attachment 4702 [details]
netsetup.log - Success!
Comment 8 Emil Konow 2009-09-15 18:13:28 UTC
Created attachment 4703 [details]
samba.log - Success!
Comment 9 Guenther Deschner 2009-10-08 08:56:37 UTC
Just for my memory: I successfully joined a Windows 2008 R2 server into a Samba controlled (master as of today) box using ldapsam and Fedora DS (needed to add the two LanManWorkstation registry patches though).
Comment 10 Karolin Seeger 2009-10-14 04:41:34 UTC
Is this one a show stopper for 3.4.3?
Comment 11 Guenther Deschner 2009-10-14 09:30:05 UTC
(In reply to comment #10)
> Is this one a show stopper for 3.4.3?

If we can reproduce, yes. Bjoern, didn't you mention you saw the same issue ?
Comment 12 Björn Jacke 2009-10-14 14:21:27 UTC
not really. I didn't try a w2k8 join though. All I can tell is that win7 joins fine.
Comment 13 Guenther Deschner 2009-10-15 16:16:42 UTC
Another reminder to myself: Installed a fresh w2k8 box, and joined it w/o any problems into a 3.4.2 PDC with ldapsam and Fedora DS.

Now, I need to check for the reporters config (tdbsam w/o scripts)
Comment 14 Guenther Deschner 2009-10-16 04:43:15 UTC
Ok, tested this successfully with 3.4.2 and origin/v3-4-test git tree as of today now also with tdbsam w/o any account management scripts, just as you have. It just worked without any problems.

No matter how hard I try, I cannot reproduce this, sorry.

Closing as worksforme with 3.4.2. If you cannot get it to work with that release, please reopen. Thanks.