Bug 670 - Compiling error in Samba 3.0 (GNU ld - SunOS 5.6)
Compiling error in Samba 3.0 (GNU ld - SunOS 5.6)
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
All Solaris
: P1 critical
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 15:14 UTC by Mark
Modified: 2004-10-29 10:58 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2003-10-22 15:14:21 UTC
Hi,

I'm trying to compile Samba 3.0 under Solaris 2.6 running on a Sparc machine
using "GNU ld" version 2.10 with BFD. Also,  I'm sure the search path is
correctly pointing to the right "ld"

But I'm getting this error:

Linking bin/smbd
/usr/local/lib/gcc-lib/sparc-sun-solaris2.6/3.1/../../../../sparc-sun-solaris2.6/bin/ld:
illegal option -- E
Comment 1 Gerald (Jerry) Carter 2003-11-04 20:09:08 UTC
Tim, can you take a look at this one?  I've not been able 
to reproduce it.
Comment 2 Gerald (Jerry) Carter 2004-10-29 07:31:21 UTC
no feedback.  Can't reproduce.  Closing.
Comment 3 Gerald (Jerry) Carter 2004-10-29 10:58:19 UTC
gaah....now I can reproduce it.  It's not actually using gnu ld 
but rather /usr/ccs/bin/ld.

Try setting 

export CC="gcc -B/path/to/directory/with/gnuld"