Bug 6699 - reloading services after sighup
reloading services after sighup
Status: RESOLVED INVALID
Product: Samba 3.3
Classification: Unclassified
Component: Client tools
3.3.2
x86 Linux
: P3 critical
: ---
Assigned To: Volker Lendecke
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-08 08:23 UTC by centaurxprc
Modified: 2009-09-18 10:59 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description centaurxprc 2009-09-08 08:23:21 UTC
Log shows a number of samaba errors having been posted. "CIFS VFS: Unexpected lookup error -22". Looking at the samaba logs I note these often happen at times of Samba to Windows Xp smb file backup activity. The linux host is connecting out (using cifs.mount) to each XP system. During these periods of activity samaba restarts with "reloading services after sighup". This breaks the processing.
Comment 1 Volker Lendecke 2009-09-08 10:27:00 UTC
Wait a second -- what are you doing exactly? You mount XP for backup purposes, and when the Samba server on the same box is getting a SIGHUP, that fails? Please describe in much more detail what you are doing, and who is sending those HUP signals where.

Volker
Comment 2 centaurxprc 2009-09-08 14:16:38 UTC
As I say I run samba on linux servers and XP boxes map to shares on those servers. Great! No problems. The linux servers also connect out to XP boxes periodically to backup files from the XP systems to hard drives on the linux boxes. While these outbound connections and activities are underway my samba server restarts with the message "reloading services after sighup". I have no idea where the handup comes from. My syslog shows messages "Unexpected lookup error -22. dmegs has entires like : 

Status code returned 0xc000000d NT_STATUS_INVALID_PARAMETER
 CIFS VFS: Unexpected lookup error -22
Status code returned 0xc000000d NT_STATUS_INVALID_PARAMETER
 CIFS VFS: Unexpected lookup error -22
Status code returned 0xc0000034 NT_STATUS_OBJECT_NAME_NOT_FOUND
Status code returned 0xc0000034 NT_STATUS_OBJECT_NAME_NOT_FOUND
Status code returned 0xc00000ca NT_STATUS_NETWORK_ACCESS_DENIED
Status code returned 0xc00000ca NT_STATUS_NETWORK_ACCESS_DENIED
Status code returned 0xc0000034 NT_STATUS_OBJECT_NAME_NOT_FOUND
Status code returned 0xc0000034 NT_STATUS_OBJECT_NAME_NOT_FOUND
 CIFS VFS: Unexpected lookup error -22
 CIFS VFS: Unexpected lookup error -22

This is chaos for connections and causes failures. I use mount.cifs to connect to the xp boxes like so mount.cifs  //host/share /mountpoint --verbose ro cred=credfile.

I hope that explains it. Thanks
Comment 3 Volker Lendecke 2009-09-08 14:21:01 UTC
Not really, sorry. You need to scan your system for cronjobs or similar things that might cause this. Please also take notes when exactly this happens, maybe there's a pattern. Maybe that job also briefly takes down your network and restarts it later. Is that possible?

BTW, what kind of system is this exactly?

Volker
Comment 4 Jeff Layton 2009-09-08 14:43:01 UTC
Sounds like this is more CIFS related than anything in samba. Recategorizing bug.

What kernel is the CIFS client running here?
Comment 5 centaurxprc 2009-09-08 16:35:18 UTC
Fedora 11 2.6.30.5-43.fc11 as of today but it has on 2 previous releases also.
Comment 6 centaurxprc 2009-09-08 16:38:36 UTC
(In reply to comment #3)
> Not really, sorry. You need to scan your system for cronjobs or similar things
> that might cause this. Please also take notes when exactly this happens, maybe
> there's a pattern. Maybe that job also briefly takes down your network and
> restarts it later. Is that possible?
> BTW, what kind of system is this exactly?
> Volker

I will try and track what is happening then. I am not aware of anything though that would bring down the network. I have no more info to offer. Thanks for your feedback anyhow. 
Comment 7 Jeff Layton 2009-09-09 06:38:27 UTC
Ok, I think you have several unrelated things going on here. Can you clarify exactly what problem you're trying to solve? Is it the SIGHUP messages? If so, then Volker is correct and you'll have to look for things that might be sending it a SIGHUP.
Comment 8 centaurxprc 2009-09-11 11:30:57 UTC
OK after a careful look. It was my code doing it. I had thought that reloading shares would not interfere with the rest of the world but alas this is not the case. I change the smb.conf file in my code and was then doing a "service smb reload" with an exec. This caused shares to be reloaded BUT it also caused some activity around interfaces with log messages such as "lib/interface.c:interpret_interface(475)" for each interface to which samaba had a bind. Each interface was "added" each time this reload took place. I am not sure exactly what this does as I have not inspected the code but I can say to you that it causes net interfaces to hiccup at least and in my case, quite coincidentally, mount.cifs connections were "interupted" and lost. I must assume any other connections may have been affected too and I will look again at mysql connections that have dropping for not clear reason over many months.

I have read on the web that samaba re-reads the conf file every 60 seconds anyway so any chages to shares will be dealt with without my intervention. If that is the case then job done for me. But should these interface "adds" take place and should the effect be to make net things unstable? Has anyonme else seen this effect?

Cheers and thanks again for your help.

Comment 9 Jeff Layton 2009-09-12 02:51:09 UTC
Glad you tracked it down...

I'll reassign this back to Volker for now since he's the better person to comment on samba's behavior.
Comment 10 Volker Lendecke 2009-09-18 10:59:50 UTC
Samba does not do anything with network interfaces, at least not knowingly. If a "service smb reload" causes network interfaces to go down and come back, something else is going on in /etc/init.d/smb. Samba itself does not do this.

I'm closing this as invalid. If you can reproduce it with just sending the HUP signal to smbd, please re-open.

Thanks,

Volker