Bug 6664 - netr_SetPassword server and client need to cope with long session keys
netr_SetPassword server and client need to cope with long session keys
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: Domain Control
3.4.0
Other Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 11:55 UTC by Guenther Deschner
Modified: 2013-12-24 12:04 UTC (History)
2 users (show)

See Also:
gd: review+
gd: review? (jra)


Attachments
patch for 3.4 (1.71 KB, patch)
2009-08-27 11:56 UTC, Guenther Deschner
no flags Details
patch for 3.4 (1.64 KB, patch)
2009-08-27 11:58 UTC, Guenther Deschner
no flags Details
patch for 3.3 (1.63 KB, patch)
2009-08-27 12:01 UTC, Guenther Deschner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2009-08-27 11:55:16 UTC
machine account password changes needs to use DES encryption routines that avoid truncation of the session key to 8 byte in case a longer key has been negotiated.
Comment 1 Guenther Deschner 2009-08-27 11:56:28 UTC
Created attachment 4600 [details]
patch for 3.4
Comment 2 Guenther Deschner 2009-08-27 11:58:26 UTC
Created attachment 4601 [details]
patch for 3.4
Comment 3 Guenther Deschner 2009-08-27 12:01:26 UTC
Created attachment 4602 [details]
patch for 3.3
Comment 4 Guenther Deschner 2009-08-27 12:09:42 UTC
review ACK
Comment 5 Guenther Deschner 2009-08-28 06:48:16 UTC
skipping jeremys ack (so we have ack from me and metze). reassigning to karolin.
Comment 6 Karolin Seeger 2009-08-28 07:18:57 UTC
Pushed, will be included in 3.4.1.
Closing out bug report.

Thanks!
Comment 7 Karolin Seeger 2009-08-31 02:55:56 UTC
Closing out bug report.
Comment 8 Karolin Seeger 2009-12-23 09:34:08 UTC
*** Bug 6998 has been marked as a duplicate of this bug. ***