Bug 6659 - Minimum Python version for Samba 4
Minimum Python version for Samba 4
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
All All
: P3 normal
: ---
Assigned To: Jelmer Vernooij
Matthias Dieter Wallnöfer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-25 10:59 UTC by Michael Ströder
Modified: 2009-08-28 04:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Ströder 2009-08-25 10:59:39 UTC
Module 'uuid' is used in the Samba 4 Python scripts (e.g. scripting/python/samba/provision.py). This module is new in Python 2.5. Therefore configure should check for minimum Python version 2.5 and fail if an older Python installation is found.
Comment 1 Michael Ströder 2009-08-25 11:11:43 UTC
Sorry, I had overlooked scripting/python/uuidmodule.c which seems to implement a wrapper module 'uuid'. Hmm, this is a name clash with module 'uuid' in Python's standard lib which could lead to problems.
Comment 2 Matthias Dieter Wallnöfer 2009-08-28 04:36:39 UTC
I think it does it appropriately right here. I'm using python 2.4 and the wrapper works fine for me. So I don't see any problems here. Closing it with INVALID (at least for now - when we don't suffer other problems).