Bug 663 - Configure does not propagate LDFLAGS correctly when checking iconv
Configure does not propagate LDFLAGS correctly when checking iconv
Status: RESOLVED DUPLICATE of bug 570
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.0
All Solaris
: P3 normal
: none
Assigned To: Jelmer Vernooij
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 10:25 UTC by Eric Boehm
Modified: 2005-11-14 09:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Boehm 2003-10-21 10:25:16 UTC
Configure is failing to find the libraries for libiconv.so because LDFLAGS is
missing -R switches that I specified when running configure. As a consequence, I
have to define LD_LIBRARY_PATH in order for configure to find libiconv.so

From config.log

grep ac_cv_env_LDFLAGS_value config.log
ac_cv_env_LDFLAGS_value='-L/usr/local/lib/sparcv9 -L/usr/local/openldap/lib
-L/usr/local/sasl/lib -L/usr/local/kerberos/lib -L/usr/local/BerkeleyDB.4.1/lib
-L/usr/local/openssl/lib -R\\$$ORIGIN -R/usr/local/lib/sparcv9
-R/usr/local/openldap/lib -R/usr/local/sasl/lib -R/usr/local/kerberos/lib
-R/usr/local/BerkeleyDB.4.1/lib -R/usr/local/openssl/lib'

configure:19698: cc -o conftest -xarch=v9a -I/usr/local/include
-I/usr/local/openldap/include -I/usr/local/sasl/include
-I/usr/local/kerberos/include -I/usr/local/BerkeleyDB.4.1/include
-I/usr/local/openssl/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-I/usr/local/include -L/usr/local/lib conftest.c  -liconv >&5

Notice that the -L and -R switches from LDFLAGS are not present
Comment 1 Gerald (Jerry) Carter 2003-11-07 06:22:59 UTC

*** This bug has been marked as a duplicate of 570 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:28:57 UTC
database cleanup