Bug 6621 - talloc fails to build on QNX 6.4.1
talloc fails to build on QNX 6.4.1
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
Other Windows XP
: P3 normal
: ---
Assigned To: Jelmer Vernooij
Matthias Dieter Wallnöfer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 15:57 UTC by Matt Kraai
Modified: 2009-08-08 04:59 UTC (History)
0 users

See Also:


Attachments
Set SONAMEFLAG to "-Wl,-soname=" on QNX (698 bytes, patch)
2009-08-07 16:02 UTC, Matt Kraai
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Kraai 2009-08-07 15:57:37 UTC
When I try to build talloc on a QNX 6.4.1 system, it fails as follows:

 gcc -shared  -o libtalloc.so.1.4.0 ./talloc.o  replace.o snprintf.o getpass.o strptime.o timegm.o   libtalloc.so.1
 gcc: libtalloc.so.1: No such file or directory

The problem is that SONAMEFLAG is empty, so gcc misinterprets "libtalloc.so.1" as a file name instead of as the SO name.

The linker on QNX accepts both -h and -soname flags to specify the SO name, so this problem can be fixed by setting SONAMEFLAG to "-Wl,-h,", "-Wl,-soname,", or "-Wl,-soname=".
Comment 1 Matt Kraai 2009-08-07 16:02:05 UTC
Created attachment 4528 [details]
Set SONAMEFLAG to "-Wl,-soname=" on QNX
Comment 2 Matthias Dieter Wallnöfer 2009-08-08 04:59:12 UTC
Thanks, applied!