Bug 6610 - mounting a s4 volume with smbfs do not allow file creation on MacOsX
mounting a s4 volume with smbfs do not allow file creation on MacOsX
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: File services
unspecified
Other Mac OS X
: P3 normal
: ---
Assigned To: Andrew Tridgell
Matthias Dieter Wallnöfer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-05 02:11 UTC by Matthieu Patou
Modified: 2009-08-05 05:24 UTC (History)
0 users

See Also:


Attachments
Tcpdump capture from a MacOSX 10.5 to a recent S4 installation (33.76 KB, application/octet-stream)
2009-08-05 02:12 UTC, Matthieu Patou
no flags Details
strace of samba -i -M single process while copying to truc3.gif (10.73 KB, application/x-bzip)
2009-08-05 04:18 UTC, Matthieu Patou
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2009-08-05 02:11:14 UTC
Trying to copy a file from a Mac to a S4 server fails (cf. packet 722 in the attached trace) when using the graphical interface.

Using smbclient is fine (cf. packet 70).

Creating directories is OK in both cases.
Comment 1 Matthieu Patou 2009-08-05 02:12:05 UTC
Created attachment 4515 [details]
Tcpdump capture from a MacOSX 10.5 to a recent S4 installation
Comment 2 Matthias Dieter Wallnöfer 2009-08-05 02:23:06 UTC
Also this seems to be related to Tridge.
Comment 3 Andrew Tridgell 2009-08-05 03:17:42 UTC
Can you organise a strace of the samba server duing this failed operation? I
suspect the problem is a failing pwrite() call, but I don't know why it
fails. A strace should tell me that.

Thanks!
Comment 4 Matthieu Patou 2009-08-05 04:18:26 UTC
Created attachment 4516 [details]
strace of samba -i -M single process while copying to truc3.gif
Comment 5 Andrew Tridgell 2009-08-05 05:24:35 UTC
fixed in 3854b5e6146ff8efeb4379a502bb083cbaa05ce4