Bug 66 - Only User = No does not work to allow any user in smbpasswd to authenticate
Only User = No does not work to allow any user in smbpasswd to authenticate
Product: Samba 3.0
Classification: Unclassified
Component: File Services
All All
: P3 normal
: none
Assigned To: Andrew Bartlett
Depends on:
  Show dependency treegraph
Reported: 2003-05-04 20:10 UTC by Marc Kaplan
Modified: 2005-02-07 07:54 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Marc Kaplan 2003-05-04 20:10:45 UTC
According to the smb.conf man page, the service parameter, "Only User = No", 
when in Share level security, should make the service not be restricted by the 
User = parameter. Instead, what should happen in share level security is the 
following: all users accounts in the password databases should be matched 
against the password supplied by the client. 

What I'm seeing is the service authentication being controller by the user = 
parameter no matter what is specified for Only User =.

Moreover, once this is fixed :), I think the default on shares should be Only 
User = Yes.
Comment 1 Gerald (Jerry) Carter 2003-12-12 08:27:37 UTC
reseting target milestone.  3.0.1 has been frozen.  WIll have to 
re-evaluate these.
Comment 2 Gerald (Jerry) Carter 2004-02-10 20:30:19 UTC
i'm marking this parameter as deprecated in 3.0
to be removed.
Comment 3 Gerald (Jerry) Carter 2005-02-07 07:54:39 UTC
originally reported against 3.0alpha23.  Bugzilla spring cleaning.