Bug 6586 - Quota support for cifsvfs
Quota support for cifsvfs
Status: RESOLVED DUPLICATE of bug 9281
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
All Linux
: P3 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-29 07:00 UTC by Juanjo Villaplana
Modified: 2014-11-06 14:40 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juanjo Villaplana 2009-07-29 07:00:11 UTC
We are using Cifs VFS to mount samba shares with unix extensions enabled.

We also used the quotas to df mapping to access user's quota info. This mapping is broken (when unix extensions are enabled) since samba-3.0.10 (see bug 5395).

I asked samba developers to reenable this mapping even for shares with unix extensions enabled, but they told me this is not an option, because unix extensions "are made to map requests 1:1". This is Cifs VFS should support quotas natively offered by samba server "over trans2 calls" (see http://samba.sernet.de/irclog/2009/07/20090729-Wed.log for more details).

The only reference I have found about quotas support in CifsVFS is in the TODO:

  A Partial List of Missing Features
  ==================================
  [...]
  g) quota support (needs minor kernel change since quota calls
  to make it to network filesystems or deviceless filesystems)

What is the current implementation status of this feature?

Best regards,
                Juanjo
Comment 1 Steve French 2009-09-25 15:43:42 UTC
Not clear to me why a Unix Query FS Info level should be different than the non-Unix QFS Info in returning either the true disk space available (vs. the disk space available to the authenticated user).

I would like to talk with VL or JRA more about what the technical issue is on the server side.
Comment 2 Björn Jacke 2014-11-06 13:00:17 UTC

*** This bug has been marked as a duplicate of bug 9281 ***