Bug 6580 - Winbind failing after a week
Winbind failing after a week
Status: RESOLVED DUPLICATE of bug 6579
Product: Samba 3.3
Classification: Unclassified
Component: Winbind
3.3.2
Other Linux
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-28 13:45 UTC by Kevin Blackwell
Modified: 2009-07-30 00:46 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Blackwell 2009-07-28 13:45:59 UTC
I don't enter bug tickets regularly, but after a week, I cannot locate fix/answer.

I'm running samba 3.3.2. WE're mostly using it to authenticate NT users through the squid proxy. Squid 3.0.STABLE13.

On a daily basis, everything runs fine. But like clockwork on a weekly basis, (7 days exactly). On the 7th day, my log.wb.$DOMAIN file grows out of hand and kills the server. It fills up with these messages.

[2009/07/09 07:11:24,  0]
rpc_client/cli_netlogon.c:rpccli_netlogon_set_trust_password(597)
 rpccli_netr_ServerPasswordSet2 failed: NT_STATUS_WRONG_PASSWORD

If I shutdown winbind, issue a 

net ads join -U Administrator%password

restart winbind

Everything returns to normal for 7 days. Then again on the 7th day past the issuing of the net ads command, it happens again.

I've took a look at the code that generated the message. Not sure what the issue is. Hopefully someone that is more familiar with the code can point me in the correct position to correct this issue.

             if (!NT_STATUS_IS_OK(result)) {
+                       DEBUG(0,("rpccli_netr_ServerPasswordSet2 failed: %s\n",
+                               nt_errstr(result)));
+                       return result;

Again, I have no idea why after a week it falls over.

Thanks
Comment 1 Kai Blin 2009-07-30 00:46:09 UTC

*** This bug has been marked as a duplicate of bug 6579 ***