Bug 6573 - Documentation Error: Section with exact title doesn't exist
Documentation Error: Section with exact title doesn't exist
Status: RESOLVED FIXED
Product: rsync
Classification: Unclassified
Component: core
3.0.6
Other All
: P3 minor
: ---
Assigned To: Wayne Davison
Rsync QA Contact
http://samba.anu.edu.au/ftp/rsync/rsy...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-23 17:54 UTC by C
Modified: 2009-08-01 13:31 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description C 2009-07-23 17:54:38 UTC
In 'man rsyncd.conf', precisely the same version as reported online here:


http://samba.anu.edu.au/ftp/rsync/rsyncd.conf.html

In section: MODULE PARAMETERS -> auth users

The section states:
"See also the "CONNECTING TO AN RSYNC DAEMON OVER A REMOTE SHELL PROGRAM" section in rsync(1) for information on how handle an rsyncd.conf-level username that differs from the remote-shell-level username when using a remote shell to connect to an rsync daemon. "

Howver, there is no section in 'man 1 rsync' titled:
CONNECTING TO AN RSYNC DAEMON OVER A REMOTE SHELL PROGRAM

But there is, instead, a section titled, "USING RSYNC-DAEMON FEATURES VIA A REMOTE-SHELL CONNECTION". 


Is this what was intended? Just making sure I'm reading the correct section. :)
Comment 1 C 2009-07-23 18:02:46 UTC
I updated this to severity minor since this may be a minor issue or even trivial compared with other issues. I'm just trying to help the QA efforts. 

The way I found this was I grepped for "CONNECTING TO AN RSYNC DAEMON OVER A REMOTE SHELL PROGRAM" after reading about it in another man page, and didn't find an exact match so I just want to let you guys know.
Comment 2 Wayne Davison 2009-08-01 13:31:49 UTC
Thanks for pointing that out!  Fixed in the git repo.