Bug 6547 - Getting a file from via a S3 smbclient on a S4 server fail
Getting a file from via a S3 smbclient on a S4 server fail
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: File services
unspecified
Other Linux
: P3 major
: ---
Assigned To: Andrew Bartlett
Matthias Dieter Wallnöfer
:
Depends on:
Blocks: 6600
  Show dependency treegraph
 
Reported: 2009-07-12 03:50 UTC by Matthieu Patou
Modified: 2009-08-04 01:03 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2009-07-12 03:50:12 UTC
From different s3 release (3.0.4, 3.2.1, 3.4rc1) I tried :

smbclient \\\\s4server\\share -U DOMAIN\\user
Then 
get file

I tried with files of a few megabytes to a few hundreds of megabytes.
Resulting file were either 0 bytes  or a few hundreds of kilobytes.
Comment 1 Matthias Dieter Wallnöfer 2009-08-03 02:37:08 UTC
I think the version numbers for SAMBA 4 Alpha/TP aren't worth to keep since we don't support any versions longer yet. Because all bugs filed will be propagated from version to version until they are fixed (for now at least) this field isn't necessary yet.
Comment 2 Andrew Tridgell 2009-08-04 01:03:35 UTC
Fixed in 1937ab3668e6a4667ac4334a6e1bea2cc75cfb1d

The problem was caused by large reads in S3 smbclient not being honoured in S4