Bug 6512 - Recurent internal error while using S3 as a print server
Recurent internal error while using S3 as a print server
Status: RESOLVED FIXED
Product: Samba 3.4
Classification: Unclassified
Component: Printing
3.4.0rc1
Other Linux
: P3 regression
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 06:39 UTC by Matthieu Patou
Modified: 2009-08-18 00:47 UTC (History)
1 user (show)

See Also:


Attachments
enumform spoolss crash fix (1.53 KB, patch)
2009-06-30 06:51 UTC, Guenther Deschner
vl: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2009-06-27 06:39:36 UTC
During the configuration of drivers parameters (for a Xerox Workcenter 133), I had several crash of samba and also some stranges messages:

[2009/06/25 19:42:56,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: _spoolss_RouterRefreshPrinterChangeNotify: Invalid handle (OTHER:4157:4169).
[2009/06/25 19:42:56,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: _spoolss_FindClosePrinterNotify: Invalid handle (OTHER:4157:4169)
[2009/06/25 19:42:56,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: find_printer_index_by_hnd: Printer handle not found: close_printer_handle: Invalid handle (OTHER:4157:4169)
[2009/06/25 19:43:09,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: find_printer_index_by_hnd: Printer handle not found: get_printer_snum: Invalid handle (OTHER:4157:4169)
[2009/06/25 19:43:09,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: find_printer_index_by_hnd: Printer handle not found: close_printer_handle: Invalid handle (OTHER:4157:4169)
[2009/06/25 19:43:10,  0] lib/fault.c:41(fault_report)
  ===============================================================
[2009/06/25 19:43:10,  0] lib/fault.c:42(fault_report)
  INTERNAL ERROR: Signal 11 in pid 4169 (3.4.0rc1)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2009/06/25 19:43:10,  0] lib/fault.c:44(fault_report)
  
  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2009/06/25 19:43:10,  0] lib/fault.c:45(fault_report)
  ===============================================================
[2009/06/25 19:43:10,  0] lib/util.c:1480(smb_panic)
  PANIC (pid 4169): internal error
[2009/06/25 19:43:10,  0] lib/util.c:1584(log_stack_trace)
  BACKTRACE: 25 stack frames:
   #0 /usr/local/sbin/smbd(log_stack_trace+0x2d) [0xb7b58d8d]
   #1 /usr/local/sbin/smbd(smb_panic+0x78) [0xb7b58eda]
   #2 /usr/local/sbin/smbd [0xb7b48478]
   #3 [0xb7850400]
   #4 /usr/local/sbin/smbd(nt_printer_publish+0x8e) [0xb7b892a7]
   #5 /usr/local/sbin/smbd(_spoolss_SetPrinter+0x3f3) [0xb7aab2a3]
   #6 /usr/local/sbin/smbd [0xb7ab9b64]
   #7 /usr/local/sbin/smbd(api_pipe_request+0x3fe) [0xb7ae9744]
   #8 /usr/local/sbin/smbd [0xb7ae33ff]
   #9 /usr/local/sbin/smbd(np_write_send+0x112) [0xb7ae3c4f]
   #10 /usr/local/sbin/smbd [0xb790f861]
   #11 /usr/local/sbin/smbd [0xb790fe8c]
   #12 /usr/local/sbin/smbd(reply_trans+0x6f2) [0xb7910a2f]
   #13 /usr/local/sbin/smbd [0xb79696a2]
   #14 /usr/local/sbin/smbd [0xb796b96f]
   #15 /usr/local/sbin/smbd [0xb796c154]
   #16 /usr/local/sbin/smbd(run_events+0x157) [0xb7b68593]
   #17 /usr/local/sbin/smbd(smbd_process+0x866) [0xb796b6c6]
   #18 /usr/local/sbin/smbd [0xb7e50e4d]
   #19 /usr/local/sbin/smbd(run_events+0x157) [0xb7b68593]
   #20 /usr/local/sbin/smbd [0xb7b68828]
   #21 /usr/local/sbin/smbd(_tevent_loop_once+0x99) [0xb7b68d51]
   #22 /usr/local/sbin/smbd(main+0x117e) [0xb7e5213a]
   #23 /lib/i686/nosegneg/libc.so.6(__libc_start_main+0xe5) [0xb740e455]
   #24 /usr/local/sbin/smbd [0xb78f2cf1]
[2009/06/25 19:43:10,  0] lib/fault.c:321(dump_core)
  dumping core in /usr/local/var/cores/smbd
[2009/06/25 19:43:10,  2] smbd/sesssetup.c:1360(setup_new_vc_session)
  setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.
[2009/06/25 19:43:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: _spoolss_RouterRefreshPrinterChangeNotify: Invalid handle (OTHER:4169:4170).
[2009/06/25 19:43:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: _spoolss_FindClosePrinterNotify: Invalid handle (OTHER:4169:4170)
[2009/06/25 19:43:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: find_printer_index_by_hnd: Printer handle not found: close_printer_handle: Invalid handle (OTHER:4169:4170)
[2009/06/25 19:44:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: find_printer_index_by_hnd: Printer handle not found: get_printer_snum: Invalid handle (OTHER:4169:4170)
[2009/06/25 19:44:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: find_printer_index_by_hnd: Printer handle not found: close_printer_handle: Invalid handle (OTHER:4169:4170)
[2009/06/25 19:44:10,  0] lib/fault.c:41(fault_report)
  ===============================================================
[2009/06/25 19:44:10,  0] lib/fault.c:42(fault_report)
  INTERNAL ERROR: Signal 11 in pid 4170 (3.4.0rc1)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2009/06/25 19:44:10,  0] lib/fault.c:44(fault_report)
  
  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2009/06/25 19:44:10,  0] lib/fault.c:45(fault_report)
  ===============================================================
[2009/06/25 19:44:10,  0] lib/util.c:1480(smb_panic)
  PANIC (pid 4170): internal error
[2009/06/25 19:44:10,  0] lib/util.c:1584(log_stack_trace)
  BACKTRACE: 25 stack frames:
   #0 /usr/local/sbin/smbd(log_stack_trace+0x2d) [0xb7b58d8d]
   #1 /usr/local/sbin/smbd(smb_panic+0x78) [0xb7b58eda]
   #2 /usr/local/sbin/smbd [0xb7b48478]
   #3 [0xb7850400]
   #4 /usr/local/sbin/smbd(nt_printer_publish+0x8e) [0xb7b892a7]
   #5 /usr/local/sbin/smbd(_spoolss_SetPrinter+0x3f3) [0xb7aab2a3]
   #6 /usr/local/sbin/smbd [0xb7ab9b64]
   #7 /usr/local/sbin/smbd(api_pipe_request+0x3fe) [0xb7ae9744]
   #8 /usr/local/sbin/smbd [0xb7ae33ff]
   #9 /usr/local/sbin/smbd(np_write_send+0x112) [0xb7ae3c4f]
   #10 /usr/local/sbin/smbd [0xb790f861]
   #11 /usr/local/sbin/smbd [0xb790fe8c]
   #12 /usr/local/sbin/smbd(reply_trans+0x6f2) [0xb7910a2f]
   #13 /usr/local/sbin/smbd [0xb79696a2]
   #14 /usr/local/sbin/smbd [0xb796b96f]
   #15 /usr/local/sbin/smbd [0xb796c154]
   #16 /usr/local/sbin/smbd(run_events+0x157) [0xb7b68593]
   #17 /usr/local/sbin/smbd(smbd_process+0x866) [0xb796b6c6]
   #18 /usr/local/sbin/smbd [0xb7e50e4d]
   #19 /usr/local/sbin/smbd(run_events+0x157) [0xb7b68593]
   #20 /usr/local/sbin/smbd [0xb7b68828]
   #21 /usr/local/sbin/smbd(_tevent_loop_once+0x99) [0xb7b68d51]
   #22 /usr/local/sbin/smbd(main+0x117e) [0xb7e5213a]
   #23 /lib/i686/nosegneg/libc.so.6(__libc_start_main+0xe5) [0xb740e455]
   #24 /usr/local/sbin/smbd [0xb78f2cf1]
[2009/06/25 19:44:10,  0] lib/fault.c:321(dump_core)
  dumping core in /usr/local/var/cores/smbd
[2009/06/25 19:44:10,  2] smbd/sesssetup.c:1360(setup_new_vc_session)
  setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.
[2009/06/25 19:44:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: _spoolss_RouterRefreshPrinterChangeNotify: Invalid handle (OTHER:4170:4171).
[2009/06/25 19:44:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: _spoolss_FindClosePrinterNotify: Invalid handle (OTHER:4170:4171)
[2009/06/25 19:44:10,  2] rpc_server/srv_spoolss_nt.c:234(find_printer_index_by_hnd)
  find_printer_index_by_hnd: Printer handle not found: find_printer_index_by_hnd: Printer handle not found: close_printer_handle: Invalid handle (OTHER:4170:4171)
Comment 1 Guenther Deschner 2009-06-30 06:50:36 UTC
I was not able to reproduce.

What I did was to install the Xerox WorkCentre 133 PCL driver and configured some settings, including publishing in AD. Unfortunately I do not have such a printer in reality, so all that testing was on a virtual printer using the xerox driver.

I found one critical crash issue which is solved in master now with commit 
b85b93dcff89e18bd15d4cef8b8c2dc61bc42cbe

Any chance to get us a backtrace of that printer publish crash ?
Comment 2 Guenther Deschner 2009-06-30 06:51:58 UTC
Created attachment 4373 [details]
enumform spoolss crash fix

Karolin, this - once reviewed - is a must for 3.4
Comment 3 Guenther Deschner 2009-07-01 03:58:29 UTC
Karolin, please push the attached (and reviewed) patch for 3.4.
Comment 4 Karolin Seeger 2009-07-01 04:16:46 UTC
Pushed, patch will be included in 3.4.0.
Comment 5 Guenther Deschner 2009-07-03 14:41:07 UTC
Matthieu, any chance to get further data ?

log level 10 or back trace of the crash would be much appreciated.
Comment 6 Matthieu Patou 2009-07-05 11:37:41 UTC
Hello Guenther,
I'll retry new version (3.4) this week. And keep you informed.
Comment 7 Karolin Seeger 2009-08-12 09:32:16 UTC
Hi Matthieu,

did you have a chance to test with 3.4.0?
Comment 8 Matthieu Patou 2009-08-17 13:15:50 UTC
Hi karolin,

I finally remade some test today with Samba 3.4.0 it seems ok now.
Let's close this bug. I'll try to test any 3.4.1rc to see if I see anything suspect.

Ok ?
Comment 9 Karolin Seeger 2009-08-18 00:47:30 UTC
(In reply to comment #8)
> Hi karolin,
> 
> I finally remade some test today with Samba 3.4.0 it seems ok now.
> Let's close this bug. I'll try to test any 3.4.1rc to see if I see anything
> suspect.
> 
> Ok ?
> 

Hi Matthieu,

ok, I'll close the bug report.
Please reopen if it still exists in 3.4.1 (will be released today).

Thanks!